Bug 221991 - data corruption bug in 2.6.18 - patch available
Summary: data corruption bug in 2.6.18 - patch available
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel   
(Show other bugs)
Version: 4.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Peter Zijlstra
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On: 220963
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-09 14:53 UTC by Linda Wang
Modified: 2014-08-11 05:40 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-07 19:07:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Comment 1 Jay Turner 2007-01-09 15:13:38 UTC
I'm confused on this one.  There are notes above which say that RHEL4 isn't
impacted.  In addition this bug is proposed for RHEL4.6.  Can someone please
describe exactly what's being requested?

Comment 2 Peter Zijlstra 2007-01-09 15:23:23 UTC
Linus suspects this bug to affect ancient kernels including the 2.6.9 series.
Rik could not reproduce it. I'll have a look at the code to see if the race is
indeed possible. RHEL4 != 2.6.9 anymore either.

Comment 3 Marizol Martinez 2007-04-12 15:29:52 UTC
Hey Peter -- Any updates on this one? Thanks!

Comment 4 Peter Zijlstra 2007-04-12 15:45:44 UTC
Yeah, I was about to close this as NOTABUG.

I can't find any races, and the few people that said they had problems with
mmap'ed files pre .19 went away - I poked a few privately but nothing came out
of that.

Comment 5 Marizol Martinez 2007-04-16 22:02:32 UTC
Thanks, Peter! Sounds like the right thing to do then. Go ahead and we'll reopen
if necessary.


Note You need to log in before you can comment on or make changes to this bug.