Bug 222075 - gnumeric crashes when printing options selected
Summary: gnumeric crashes when printing options selected
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: libgnomeprint (Show other bugs)
(Show other bugs)
Version: 6
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Hans de Goede
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-10 01:20 UTC by Enrique Gomezdelcampo
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-15 15:15:24 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Enrique Gomezdelcampo 2007-01-10 01:20:29 UTC
Description of problem:
Gnumeric crashes when selecting the Print Preview or Print option in the file menu

Version-Release number of selected component (if applicable):
gnumeric-1.6.3-5.fc6

How reproducible:
every time.

Steps to Reproduce:
1. start gnumeric either from a terminal or from the main menu 
2. click on File -> Print Preview or File -> Print
3. gnumeric crashes
  
Actual results:
When starting gnumeric from a terminal it send this message when crashing:
** (bug-buddy:22166): WARNING **: Couldn't load icon for Open Folder

Expected results:


Additional info:

Comment 1 Enrique Gomezdelcampo 2007-01-12 14:43:11 UTC
I'm getting this error messages when gnumeric crashes under the same
circumstances as above (print options):

(gnumeric:2862): GLib-CRITICAL **: g_strrstr: assertion `haystack != NULL' failed

(gnumeric:2862): GLib-CRITICAL **: g_strrstr: assertion `haystack != NULL' failed

(gnumeric:2862): GLib-CRITICAL **: g_strrstr: assertion `haystack != NULL' failed

** (bug-buddy:2869): WARNING **: Couldn't load icon for Open Folder

Comment 2 Enrique Gomezdelcampo 2007-01-12 15:05:51 UTC
I just realized that this is a problem with all Gnome applications using
printing, namely: gnumeric, abiword, gedit, evolution, etc. Exactly same
behavior as above. Application crashes when printing options selected. Error
output just as above. Please help me fix this bug. Thanks.

Comment 3 Hans de Goede 2007-01-15 15:15:24 UTC
I cannot reproduce this on my fully up2date rawhide system, so I guess its
already fixed. Have you applied all updates for FC-6? A lot of gnome updates
have been released for FC-6.

I'm reassigning this to libgnomeprint (most likely suspect since multliple apps
are affected) and closing this with a resolution of RAWHIDE as its fixed there.



Note You need to log in before you can comment on or make changes to this bug.