Bug 222099 - print functions do not treat control characters.
Summary: print functions do not treat control characters.
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: ncurses   
(Show other bugs)
Version: 4.4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Miroslav Lichvar
QA Contact: Jay Turner
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 234251 236329
TreeView+ depends on / blocked
 
Reported: 2007-01-10 11:26 UTC by Jose Plans
Modified: 2018-10-19 21:21 UTC (History)
3 users (show)

Fixed In Version: RHBA-2007-0711
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-15 15:57:19 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ncurses_test.c (292 bytes, text/x-csrc)
2007-01-10 11:26 UTC, Jose Plans
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2007:0711 normal SHIPPED_LIVE ncurses bug fix update 2007-11-14 16:31:22 UTC

Comment 14 Jay Turner 2007-01-11 11:18:56 UTC
QE ack for RHEL4.5.

Comment 19 Thomas E. Dickey 2007-01-15 01:29:47 UTC
not a bug.  The example is emitting 8-bit characters
in POSIX locale (which makes them non-printable).
It doesn't provide any information on what the code
is supposed to produce, nor the environment in which
it runs.

Comment 20 Miroslav Lichvar 2007-01-15 08:10:05 UTC
Thomas, this is the bug fixed in patch 20050320 and 20050327, the particular
locale is EUC-JP.

Comment 22 Thomas E. Dickey 2007-01-17 01:29:29 UTC
oh (then I'm confused -sorry).

Comment 25 RHEL Product and Program Management 2007-03-16 16:06:24 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 29 errata-xmlrpc 2007-11-15 15:57:19 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0711.html



Note You need to log in before you can comment on or make changes to this bug.