Bug 222100 - Flash plugin doesn't install in Firefox
Flash plugin doesn't install in Firefox
Status: CLOSED DUPLICATE of bug 189622
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
https://bugzilla.redhat.com/bugzilla/...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-10 06:31 EST by Răzvan Sandu
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-10 15:26:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Răzvan Sandu 2007-01-10 06:31:05 EST
Description of problem:

Hello,

When visiting a page made in Flash, Firefox tries to install the missing plugin.
User is prompted to allow installation.
License screen appears, user selects "I accept" and goes on.
Firefox reports that plugin is succesfully installed, however the notification
for installing plugin keeps reapearing and page's Flash content remains invisible.

It does not matter if user is root or not (installing the plugin as root is
expected to make it available for all system users).


Is it possible that this is related to bug #207621 from FC6test3 ?


Regards,
Răzvan


Version-Release number of selected component (if applicable):
firefox-1.5.0.9
(stock Fedora Core 6 + updates)

How reproducible:
Always.

Steps to Reproduce:
1.
2.
3.
  
Actual results:
The flash content of the page remains invisible after plugin installation.

Expected results:
The flash content of the page should became visible without any manual hack of
configuration files.

Additional info:
Comment 1 Warren Togami 2007-01-10 15:26:05 EST
This is due to Bug #189622 where Flash Player 7 using text relocations, which is
disallowed by selinux policy.  

Flash Player 9 due out soon fixes this problem.

Meanwhile, you can either:
1) http://macromedia.mplug.org/ Use the Flash Player 7 RPM from here which
avoids this problem.
2) http://labs.adobe.com/downloads/flashplayer9.html Use Flash Player 9 Beta2
3) Wait until Flash Player 9 is released soon.


*** This bug has been marked as a duplicate of 189622 ***

Note You need to log in before you can comment on or make changes to this bug.