Bug 222104 - invalid name: "0x92c1250/bonobo_iid"
invalid name: "0x92c1250/bonobo_iid"
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gnome-applets (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-10 07:38 EST by QingLong
Modified: 2008-04-08 10:21 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-18 14:41:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 395035 None None None Never

  None (edit)
Description QingLong 2007-01-10 07:38:29 EST
Description of problem:
On gnome session starting (just after login) I get error notifications.
The locale is russion and the messages actually appear in russian,
so this is back translated to english (may differ from the original):

An error has occured during loading or saving configuration information for
Null-Applet. Some settings (?) can mailfunction.

Key (switch?) or directory name is invalid: "0x92c1250/bonobo_iid": Must begin
with "/" character.

The latter line is repeated many times with different hex numbers.
I have tried to find those strings (hex numbers and "bonobo_iid") in files
in my ~/ recursively, but have found none.

After closing those error notification windows the gnome session appears
to go on rather well.


Version-Release number of selected component (if applicable):
2.16.0-1.fc6

How reproducible:
100%

Steps to Reproduce:
Just login to gnome session.

Actual results:
Strange error notifications come out.

Expected results:
Null-Applet should not suffer from such problems.

Additional info:
Actually I don't know what system part is in response for this problem.
This is the list of (maybe) relevant packages installed on the system:
GConf2-2.14.0-8.fc6
GConf2-devel-2.14.0-8.fc6
gnome-applets-2.16.0.1-12.fc6
gnome-python2-applet-2.16.0-1.fc6
gnome-python2-bonobo-2.16.2-2.fc6
gnome-python2-gconf-2.16.2-2.fc6
gnome-session-2.16.0-7.fc6
libbonobo-2.16.0-1.fc6
libbonoboui-2.16.0-1.fc6
Comment 1 Ray Strode [halfline] 2007-01-10 09:51:21 EST
I've run into this before.  There is a %p instead of a %s somewhere in the null
applet code.  Let me see if I can find the report, and figure out where the fix
went (it obviously missed the fc6 tree if you're hitting the issue)
Comment 2 Ray Strode [halfline] 2007-01-10 09:54:42 EST
bug 219807 is a RHEL bug.

It doesn't have an upstream report attached to it, and I can't find a
corresponding fedora report.  It looks like I dropped the ball on this one.
Comment 3 Ray Strode [halfline] 2007-01-10 10:49:13 EST
Can you try gnome-applets-2.16.0.1-13.fc6 when it lands in -updates-testing ?

It's building now.
Comment 4 QingLong 2007-01-11 04:33:32 EST
I don't see it in
http://download.fedora.RedHat.com/pub/fedora/linux/core/updates/testing/6/i386/.
Would you be so kind as to tell me where should I look for the rpm package?
Comment 5 Ray Strode [halfline] 2007-01-11 07:50:03 EST
that will be the place.  Release engineering hasn't pushed it yet.
Comment 6 Fedora Update System 2007-01-11 10:51:35 EST
gnome-applets-2.16.0.1-13.fc6 has been pushed for fc6, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 7 Ray Strode [halfline] 2008-03-18 14:41:41 EDT
Hi,

We no longer support Fedora Core 6 and I am currently trying to get my open bug
count down to a more manageable state.  I'm going to close this bug as WONTFIX.
 If this issue is still a concern for you, would you mind trying to reproduce on
a supported version of Fedora and reopening?

(this is a mass message)
Comment 8 QingLong 2008-04-08 09:04:33 EDT
>
> We no longer support Fedora Core 6 ... would you mind trying
> to reproduce on a supported version of Fedora and reopening?
>
   To my regret I cannot upgrade to a later Fedora release
as since Fedora 7 PATA disks are always treated as SCSI disks
and SCSI disks cannot contain more than 15 partitions,
while I do have more than twenty of them.
It seems I should have to switch to some other Linux distribution.
Comment 9 Ray Strode [halfline] 2008-04-08 09:34:36 EDT
Out of curiosity, did you file a bug about your "Can't have more than 15
partitions issue?"

I don't know if it would help, but might be worth a shot.
Comment 10 QingLong 2008-04-08 10:08:53 EDT
No, I haven't submitted such a report.
If I'd tried to, then what subsystem/package/category should it go to?
It's more ideological issue than a real technical one.
Moreover, I am quite sure what would they answer me,
they would suggest me to use LVM and close the bug.
Well I have tried using LVM as a replacement for partitioning,
but it turned out to be much harder to manage and maintain
especially if one wants to create a copy of the system,
or to move a disk from one machine to another.
Not mentioning performance and resource penalties of LVM.
IMHO Fedora has got a wrong turn and is moving off from the right way. :(
Comment 11 Ray Strode [halfline] 2008-04-08 10:21:15 EDT
If you file it against kernel, the bug report should get directed to the right
people.

Note You need to log in before you can comment on or make changes to this bug.