Bug 222111 - file conflicts in plib16-devel with plib-devel
file conflicts in plib16-devel with plib-devel
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: plib16 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Saou
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-10 09:28 EST by Hans de Goede
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-06 07:13:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hans de Goede 2007-01-10 09:28:06 EST
Description of problem:
bugs.michael@gmx.net today send an email to the Fedora Extras list about
potential file conflicts in FE. One problem is a file conflict between
plib-devel and plib16-devel which both install files under /usr/include/plib. I
believe that plib16-devel should install its files under /usr/include/plib16 and
apps using it should be patched accordingly. Alternativly we could add a
Conflicts: plib-devel to plib16-devel, or completely kill plib16 usage although
I don't know how hard that will be.
Comment 1 Matthias Saou 2007-01-10 09:30:59 EST
First things first : Check if plib16 isn't obsolete by now. I remember having
kept it around for some games that still hadn't been ported to plib 1.8, but
maybe they all have by now. Grepping through build requirements for plib16-devel
should tell us very quickly ;-)
Comment 2 Matthias Saou 2007-02-02 07:22:32 EST
I took the time to check, and indeed plib16-devel isn't buildreq'd by anything
in Fedora 7 (as it was expected), so I've retired the package.
Comment 3 Ville Skyttä 2007-07-28 14:11:15 EDT
Looks like something has gone wrong with retiring it, plib16 is still present in
the F7 and development repos.  Contact rel-eng?
http://fedoraproject.org/wiki/PackageMaintainers/PackageEndOfLife
Comment 4 Matthias Saou 2007-08-06 07:13:25 EDT
Done, thanks for catching this. No more plib16 in the development tree.

Note You need to log in before you can comment on or make changes to this bug.