Bug 222121 - X server crashes upon startup
X server crashes upon startup
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-10 10:49 EST by Steven Usdansky
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-27 11:59:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg log file (15.99 KB, text/plain)
2007-01-17 11:20 EST, Steven Usdansky
no flags Details
Xorg.0.log when using FC6 xorg (41.31 KB, text/plain)
2007-05-26 19:50 EDT, Steven Usdansky
no flags Details

  None (edit)
Description Steven Usdansky 2007-01-10 10:49:34 EST
Description of problem:
X server crashes upon startup

~/tma/xorg$ startx -- :1
xauth:  creating new authority file /home/a/.serverauth.2668




Version-Release number of selected component (if applicable):
xorg-x11-server-Xorg-1.1.1-57.fc7

How reproducible:
Always

Steps to Reproduce:
1. boot into runlevel 3
2. type "startx" at the bash prompt

  
Actual results:
~/tma/xorg$ startx -- :1
xauth:  creating new authority file /home/a/.serverauth.2668



X Window System Version 7.1.1
Release Date: 12 May 2006
X Protocol Version 11, Revision 0, Release 7.1.1
Build Operating System: Fedora Core 7 Red Hat, Inc.
Current Operating System: Linux hercynite 2.6.18-1.2849.fc6 #1 SMP Fri Nov 10
12:45:28 EST 2006 i686
Build Date: 09 January 2007
Build ID: xorg-x11-server 1.1.1-57.fc7 
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.1.log", Time: Wed Jan 10 09:32:37 2007
(==) Using config file: "/etc/X11/xorg.conf"
(EE) VESA(0): No matching modes
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found
XIO:  fatal IO error 104 (Connection reset by peer) on X server ":1.0"
      after 0 requests (0 known processed) with 0 events remaining.


Expected results:
X starts normally

Additional info:
reverting to xorg-X11-server-xorg-1.1.1-47.1.fc6 eliminates the problem
I have not change /etc/X11/xorg.conf. Relevant (I hope) sections listed below:
Section "Monitor"
	Identifier   "Monitor0"
	VendorName   "Monitor Vendor"
	ModelName    "Unknown monitor"
 ### Comment all HorizSync and VertSync values to use DDC:
	HorizSync    28.0 - 96.0
	VertRefresh  50.0 - 75.0
	Option	    "dpms"
EndSection

Section "Device"
	Identifier  "Videocard0"
	Driver      "vesa"
	VendorName  "Videocard vendor"
	BoardName   "S3 UniChrome"
EndSection

Section "Screen"
	Identifier "Screen0"
	Device     "Videocard0"
	Monitor    "Monitor0"
	DefaultDepth     24
	SubSection "Display"
		Viewport   0 0
		Depth     24
		Modes    "1024x768" "800x600" "640x480"
	EndSubSection
EndSection

Section "DRI"
	Group        0
	Mode         0666
EndSection
Comment 1 Matěj Cepl 2007-01-11 06:18:51 EST
Is it upgrade or fresh install on cleaned up partition?
Comment 2 Steven Usdansky 2007-01-11 10:19:56 EST
It is not a fresh install, but a rolling update. 
Comment 3 Adam Jackson 2007-01-17 10:31:52 EST
Please attach the /var/log/Xorg.0.log from the failed server startup.
Comment 4 Steven Usdansky 2007-01-17 11:20:16 EST
Created attachment 145833 [details]
xorg log file

sorry about the delay - I don't have Internet access every day
Comment 5 Steven Usdansky 2007-01-24 20:15:50 EST
having the same problem with xorg-x11-server-Xorg-1.2.0-1.fc7.i386 (still the
rolling upgrade)
Comment 6 Adam Jackson 2007-01-25 14:23:05 EST
The BIOS should list some modes to choose from after the

(II) VESA(0): Searching for matching VESA mode(s):

line in the log, but apparently it's not listing any at all.  The most likely
suspect in the change history would be -49, where I switched us to using x86emu
everywhere.  So presumably the emulator is buggy.  Whee.

That said, your chip _is_ supported by the via driver in FC6; is there a reason
you're using vesa instead?
Comment 7 Steven Usdansky 2007-01-30 20:03:48 EST
The reason for not using the via driver is that it causes X to lock up when the
rt2500 (wireless) module is loaded. 
Comment 8 Adam Jackson 2007-03-27 11:59:22 EDT
The log is showing _zero_ modes from the VESA BIOS, which means there's really
nothing we can do about that.

Should definitely file the rt2500 bug though, that sounds pretty serious.
Comment 9 Steven Usdansky 2007-05-26 19:50:24 EDT
Created attachment 155514 [details]
Xorg.0.log when using FC6 xorg

my xorg files for the test:

~$ rpm -qa | grep xorg | sort
xorg-x11-apps-7.1-3.fc6.i386
xorg-x11-drv-dummy-0.2.0-3.fc7.i386
xorg-x11-drv-evdev-1.1.2-2.1.i386
xorg-x11-drv-fbdev-0.3.0-2.i386
xorg-x11-drv-keyboard-1.1.0-3.fc7.i386
xorg-x11-drv-mouse-1.1.1-1.1.i386
xorg-x11-drv-penmount-1.1.0-3.fc7.i386
xorg-x11-drv-s3-0.5.0-3.fc7.i386
xorg-x11-drv-s3virge-1.9.1-3.fc7.i386
xorg-x11-drv-vesa-1.2.1-4.i386
xorg-x11-drv-vga-4.1.0-2.1.i386
xorg-x11-drv-via-0.2.1-7.i386
xorg-x11-drv-vmmouse-12.4.0-2.1.i386
xorg-x11-drv-vmware-10.14.1-1.fc7.i386
xorg-x11-drv-void-1.1.0-3.1.i386
xorg-x11-filesystem-7.1-2.fc6.noarch
xorg-x11-fonts-100dpi-7.1-3.fc7.noarch
xorg-x11-fonts-75dpi-7.1-3.fc7.noarch
xorg-x11-fonts-base-7.1-3.fc7.noarch
xorg-x11-fonts-ISO8859-1-100dpi-7.1-3.fc7.noarch
xorg-x11-fonts-ISO8859-1-75dpi-7.1-3.fc7.noarch
xorg-x11-fonts-misc-7.1-3.fc7.noarch
xorg-x11-fonts-truetype-7.1-2.noarch
xorg-x11-fonts-Type1-7.1-3.fc7.noarch
xorg-x11-font-utils-7.1-5.fc7.i386
xorg-x11-proto-devel-7.2-9.fc7.i386
xorg-x11-resutils-7.1-2.fc6.i386
xorg-x11-server-utils-7.1-4.fc6.i386
xorg-x11-server-Xorg-1.1.1-47.fc6.i386
xorg-x11-server-Xvfb-1.1.1-47.fc6.i386
xorg-x11-twm-1.0.1-3.1.i386
xorg-x11-util-macros-1.0.2-4.fc6.i386
xorg-x11-utils-7.1-2.fc6.i386
xorg-x11-xauth-1.0.1-2.1.i386
xorg-x11-xbitmaps-1.0.1-4.1.i386
xorg-x11-xfs-1.0.2-3.1.i386
xorg-x11-xfs-utils-1.0.2-3.1.i386
xorg-x11-xinit-1.0.2-12.fc6.i386
xorg-x11-xkb-utils-1.0.2-2.1.i386

Note You need to log in before you can comment on or make changes to this bug.