Bug 22215 - mount 2.10m doesn't support NFS v3 from a 2.2.18 server
Summary: mount 2.10m doesn't support NFS v3 from a 2.2.18 server
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: mount   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
high
high
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-12-13 11:35 UTC by Yusuf Goolamabbas
Modified: 2005-10-31 22:00 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-13 11:35:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Yusuf Goolamabbas 2000-12-13 11:35:38 UTC
Hi, I have a Linux 2.2.18 machine [Redhat 6.2] from which I export /home to
another machine which has Redhat 7.0 with errata installed. The client
machine also has 2.2.18 installed. In both machines, NFS v3 client/server
support were enabled via make menuconfig. Both machines have the latest
nfs-utils from http://nfs.sourceforge.net/

On the RH 6.2 machine 192.168.2.3 which is configured as a NFS server, I
modify /etc/exports to the following

/home 192.168.2.2(rw)

On the RH 7.0 machine [192.168.2.2], I mount the export via the following
command

mount -t nfs -orsize=32768,wsize=32768,nfsvers=3 192.168.2.3:/home /mnt/home

This results in the following message

NFSv3 not supported!
mount: wrong fs type, bad option, bad superblock on 202.77.181.217:/home,
       or too many mounted file systems

I tried using mount-2.10o from Rawhide but it gave the same result

However, If I reverse the roles of the machines, then mount-2.10f on the RH
6.2 box seems to be able to mount a filesystem from the RH 7.0 box as a NFS
v3 mount

According to a message on nfs@lists.sourceforge.net, this is what Trond


     > Confused,

It is 'mount' itself that saying so because it believes your kernel is
too old to support NFSv3. Remember official support for NFSv3 goes in
as of kernel 2.2.18 only.

Try editing the line

        else if (kernel_version < MAKE_VERSION(2,2,18))
                nfs_mount_version = 3;
to read
        else if (kernel_version < MAKE_VERSION(2,2,17))
                nfs_mount_version = 3;

(or whatever) depending on which NFSv3-patched kernel you're using.

This patch also seems to be available at this URL

http://www.fys.uio.no/~trondmy/src/nfsv3-mount/util-linux-2.10o-nfsv3.dif

Request a release of a mount RPM which is capable of mounting NFS v3 mounts
from Linux servers

Comment 1 Bernhard Rosenkraenzer 2000-12-13 11:56:32 UTC
The "fix" you suggest isn't necessary, however, updating mount to 2.0r is. 2.0f
is way too old to know about 2.2.x kernels that support NFSv3.

2.0r is in the internal tree for the next release already.


Comment 2 Bernhard Rosenkraenzer 2000-12-13 11:56:54 UTC
(meaning it will be in Rawhide in a couple of days)

Comment 3 Yusuf Goolamabbas 2001-01-01 14:44:37 UTC
Bero, Any idea when util-linux 2.10r will show up in rawhide. It's been close to
two weeks after your message and I see only util-linux 2.10p in rawhide

Cheers, Yusuf


Comment 4 Bernhard Rosenkraenzer 2001-01-01 15:22:55 UTC
Argh, the package was rejected because it doesn't build on ia64. :/
You can get it from http://www.linux-easy.com/rh-updates/ while I'm fixing the
build.



Note You need to log in before you can comment on or make changes to this bug.