Bug 222150 - in.ntalkd can't read /var/run/utmp
Summary: in.ntalkd can't read /var/run/utmp
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted   
(Show other bugs)
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-10 18:08 UTC by Dax Kelson
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version: Current
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-22 14:12:33 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Dax Kelson 2007-01-10 18:08:59 UTC
Description of problem:
Use of talk/ytalk is failing because the daemon in.ntalkd is being prevented
from reading /var/run/utmp.

Jan 10 10:51:43 station4 kernel: audit(1168451503.142:32): avc:  denied  { read
} for  pid=5885 comm="in.ntalkd" name="utmp" dev=sda6 ino=26529
scontext=root:system_r:inetd_child_t:s0
tcontext=system_u:object_r:initrc_var_run_t:s0 tclass=file

Using: selinux-policy-targeted-2.4.6-17.fc6

Comment 1 Daniel Walsh 2007-01-10 20:02:08 UTC
Could you please execute 

setenforce 0
chcon -t ktalkd_exec_t /usr/sbin/in.talkd 
service xinetd restart
Do your talk test.
setenforce 1

And send me the avc messages.



Comment 2 Dax Kelson 2007-01-10 20:17:13 UTC
/usr/sbin/in.talkd is a symlink to /usr/sbin/in.ntalkd

Here are your messages you want:

Jan 10 13:15:46 station8 kernel: audit(1168460146.105:13): avc:  denied  {
getattr } for  pid=11992 comm="in.ntalkd" name="tty1" dev=tmpfs ino=1431
scontext=root:system_r:ktalkd_t:s0 tcontext=root:object_r:tty_device_t:s0
tclass=chr_file
Jan 10 13:15:46 station8 kernel: audit(1168460146.105:14): avc:  denied  {
search } for  pid=11992 comm="in.ntalkd" name="/" dev=devpts ino=1
scontext=root:system_r:ktalkd_t:s0 tcontext=system_u:object_r:devpts_t:s0 tclass=dir
Jan 10 13:15:46 station8 kernel: audit(1168460146.105:15): avc:  denied  {
getattr } for  pid=11992 comm="in.ntalkd" name="1" dev=devpts ino=3
scontext=root:system_r:ktalkd_t:s0 tcontext=root:object_r:devpts_t:s0
tclass=chr_file
Jan 10 13:15:46 station8 kernel: audit(1168460146.105:16): avc:  denied  { write
} for  pid=11998 comm="in.ntalkd" name="2" dev=devpts ino=4
scontext=root:system_r:ktalkd_t:s0 tcontext=root:object_r:devpts_t:s0
tclass=chr_file


Comment 3 Daniel Walsh 2007-01-10 20:49:28 UTC
Fixed in selinux-policy-2.4.6-25

Comment 4 Daniel Walsh 2007-08-22 14:12:33 UTC
Fixed in current release


Note You need to log in before you can comment on or make changes to this bug.