Bug 222174 - FC6 fails to install using ata_piix driver on Toshiba Portege S100
FC6 fails to install using ata_piix driver on Toshiba Portege S100
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-10 13:55 EST by Max E
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-11 11:44:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lspci -v output from Toshiba Portege laptop (7.33 KB, text/plain)
2007-01-10 13:55 EST, Max E
no flags Details
Ubuntu 6.10 dmesg (25.07 KB, text/plain)
2007-01-10 17:26 EST, Max E
no flags Details
Fedora Core 6 dmesg from Toshiba (16.00 KB, text/plain)
2007-01-11 10:31 EST, Max E
no flags Details

  None (edit)
Description Max E 2007-01-10 13:55:08 EST
Description of problem:

Trying to install FC6 onto my new Toshiba Portege S100.  I know there are 
problems with the ata_piix driver, and you have to wait for a timeout to occur 
on the install process, but FC6 cannot still cannot see the HD.

There is no 'legacy' mode for the HD in the BIOS on the laptop, so I am rather 
stuck.  linux-laptops recommend that you use an external CDROM drive (which I 
don't have access to at the moment).

Version-Release number of selected component (if applicable):

Fedora Core 6 - Vanilla - 2.6.18-1.2798.fc6

How reproducible:

Everytime

Steps to Reproduce:
1. Put FC6 DVD into drive.
2. Gets to point that it detects SATA drive, and there is a pause (1 min long)
3. Get to the partitioning screen (Installation requires partitioning of your 
drive etc etc etc), but no HD are found.
  
Actual results:

Cannot continue with the installation

Expected results:

Should have found the SATA drive and continued the installation.

Additional info:

Rather annoying, because Ubuntu 6.10 seems to recognise the HD when installing -
 their version of the kernel obviously works from the off.  I have used their 
live CD to print out lspci information.  I don't really care for brown screens.
Comment 1 Max E 2007-01-10 13:55:08 EST
Created attachment 145274 [details]
lspci -v output from Toshiba Portege laptop
Comment 2 Konrad Rzeszutek 2007-01-10 14:08:39 EST
Max,

What are the modules that Ubuntu has loaded for that device? Can you attach the
dmesg for FC and Ubuntu as well?

Thanks,
Comment 3 Max E 2007-01-10 17:25:00 EST
Hi Konrad,

As requested - dmesg from Ubuntu 6.10.

Can you tell me what I need to type to get my USB memory key mounted from the
install SH prompt - dmesg on FC6 can see the usb device, but has not allocated
it a /dev/sd[x] drive mapping.  I have typed dmesg >> fc6dmesg.txt but I cannot
mount my USB as yet.

Thanks for your help so far.

Max





Comment 4 Max E 2007-01-10 17:26:22 EST
Created attachment 145289 [details]
Ubuntu 6.10 dmesg
Comment 5 Konrad Rzeszutek 2007-01-11 10:05:28 EST
In regards to your USB device, make sure you have 'usb-storage' and 'sd-mod'
modules loaded. That should make the USB memory key show up.

In regards to your storage device, Ubuntu shows that the 'ahci' driver is
loaded, while with Fedora Core it is 'ata_piix'. There is a over-ride bootup
parameter for that (so that you can force Fedora to load 'ahci') but I cannot
remember it. I am CC-ing Bill Nottingham on this BZ who might have a better
memory that I do :-)
Comment 6 Max E 2007-01-11 10:31:04 EST
Created attachment 145355 [details]
Fedora Core 6 dmesg from Toshiba
Comment 7 Max E 2007-01-11 10:36:12 EST
Hi Konrad,

Yes, actually I think we managed to submit to the same bug at the same time! 
Anyway, I fixed the problem with the usb-storage by actually having it plugged
in at the time of kernel startup, instead of plugging the key after the kernel
startup.  

I have uploaded the dmesg from FC6 on the Toshiba.

Thanks

Max
Comment 8 Bill Nottingham 2007-01-11 10:54:18 EST
Actually, there isn't an override - we just load both modules, and let them sort
it out.
Comment 9 Bill Nottingham 2007-01-11 10:55:11 EST
Whoops, I forgot - if you pass 'noprobe', you can pick the driver. But that's
not specific to ata_piix/ahci.
Comment 10 Max E 2007-01-11 11:06:57 EST
Well, let me work on pushing the ahci driver to the disc bus and see what
happens.  What does concern is that if Ubutnu can pick out the correct driver,
why does FC6 not correctly pick out the driver???  

Just a thought on the selecting the correct driver - would passing 'ide=ahci'
help at all? 
Comment 11 Max E 2007-01-11 11:41:29 EST
Yes, thank you chaps.  That worked, and my Tosh is now running FC6 happily.  

Could you fix (if poss) the problem with the incorrect driver being detected?

Thanks

Max
Comment 12 Konrad Rzeszutek 2007-01-11 12:06:51 EST
Max,

Which workaround worked. The 'noprobe' or the 'ide=ahci' ?
Comment 13 Max E 2007-01-11 12:10:59 EST
Hi Konrad,

The 'linux noprobe' option, and selecting the ahci driver manually worked
correctly.  I didn't try the other one, although...it might work in therory (I
am not totally sure of the kernel arguments...Bill - is the 'ide=ahci' a valid
argument??)

Max
Comment 14 Bill Nottingham 2007-01-11 12:18:27 EST
Not sure on ide=ahci - someone kernel side would have to comment. It won't
change what drivers get loaded, but it might change how they respond once they
do get loaded.

Note You need to log in before you can comment on or make changes to this bug.