Bug 222239 - 'yum update' failed w/'Segmentation fault' during or after 'Running Transaction Test'
'yum update' failed w/'Segmentation fault' during or after 'Running Transacti...
Status: CLOSED DUPLICATE of bug 222238
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
6
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-10 19:00 EST by Lee Newcomb
Modified: 2014-01-21 17:56 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-10 19:06:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lee Newcomb 2007-01-10 19:00:32 EST
Description of problem:

During a "yum update", root had completed any dependency resolution, downloaded 
headers, asked if downloading 8.0M was OK (answered "y"), downloaded the 11 
packages, and was doing (or completed) the "Running Transaction Test" step.
Then a "Segmentation fault" was displayed and root got it's cmd. prompt 
displayed :(
Any attempt to use yum (e.g., "yum list", "yum --version", "yum clean"...) 
failed starting with the 2 msg's:
    Loading "installonlyn" plugin
    rpmdb: Locker is not valid



Version-Release number of selected component (if applicable):
    Unable to do "yum --version"

How reproducible:
I am assuming this would be reproducible if I could use yum again.  Assuming 
rpmdb has a problem, I will try again if there is a special step to rebuild 
what yum requires.

Steps to Reproduce:
1.  yum update
2.  y
3.  yum --version
  
Actual results:
[root@localhost ~]# yum --version
Loading "installonlyn" plugin
rpmdb: Locker is not valid
rpmdb: Unknown locker ID: 8a
error: db4 error(22) from db->close: Invalid argument
error: cannot open Packages index using db3 - Invalid argument (22)
error: cannot open Packages database in /var/lib/rpm
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in ?
    yummain.main(sys.argv[1:])
  File "/usr/share/yum-cli/yummain.py", line 85, in main
    base.getOptionsConfig(args)
  File "/usr/share/yum-cli/cli.py", line 199, in getOptionsConfig
    errorlevel=opts.errorlevel)
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 125, in 
doConfigSetup
    self.conf = config.readMainConfig(startupconf)
  File "/usr/lib/python2.4/site-packages/yum/config.py", line 597, in 
readMainConfig
    yumvars['releasever'] = _getsysver(startupconf.installroot, 
startupconf.distroverpkg)
  File "/usr/lib/python2.4/site-packages/yum/config.py", line 656, in _getsysver
    idx = ts.dbMatch('provides', distroverpkg)
TypeError: rpmdb open failed
[root@localhost ~]# 


Expected results:
  Updated fedora core 6

Additional info:
  Here is the term. log of the initial "yum update" run:

[root@localhost ~]# yum update
Loading "installonlyn" plugin
Setting up Update Process
Setting up repositories
Reading repository metadata in from local files
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for dbus to pack into transaction set.
dbus-1.0.1-9.fc6.i386.rpm 100% |=========================|  21 kB    00:00     
---> Package dbus.i386 0:1.0.1-9.fc6 set to be updated
---> Downloading header for dbus-x11 to pack into transaction set.
dbus-x11-1.0.1-9.fc6.i386 100% |=========================|  17 kB    00:00     
---> Package dbus-x11.i386 0:1.0.1-9.fc6 set to be updated
---> Downloading header for setup to pack into transaction set.
setup-2.6.1.1-1.fc6.noarc 100% |=========================|  18 kB    00:00     
---> Package setup.noarch 0:2.6.1.1-1.fc6 set to be updated
---> Downloading header for xterm to pack into transaction set.
xterm-223-1.fc6.i386.rpm  100% |=========================|  11 kB    00:00     
---> Package xterm.i386 0:223-1.fc6 set to be updated
---> Downloading header for krb5-libs to pack into transaction set.
krb5-libs-1.5-13.i386.rpm 100% |=========================|  35 kB    00:00     
---> Package krb5-libs.i386 0:1.5-13 set to be updated
---> Downloading header for krb5-workstation to pack into transaction set.
krb5-workstation-1.5-13.i 100% |=========================|  44 kB    00:00     
---> Package krb5-workstation.i386 0:1.5-13 set to be updated
---> Downloading header for krb5-devel to pack into transaction set.
krb5-devel-1.5-13.i386.rp 100% |=========================|  39 kB    00:00     
---> Package krb5-devel.i386 0:1.5-13 set to be updated
---> Downloading header for xtide-common to pack into transaction set.
xtide-common-2.9-0.2.date 100% |=========================| 7.7 kB    00:00     
---> Package xtide-common.i386 0:2.9-0.2.date20070108.fc6 set to be updated
---> Downloading header for xtide to pack into transaction set.
xtide-2.9-0.2.date2007010 100% |=========================|  13 kB    00:00     
---> Package xtide.i386 0:2.9-0.2.date20070108.fc6 set to be updated
---> Downloading header for xorg-x11-server-Xorg to pack into transaction set.
xorg-x11-server-Xorg-1.1. 100% |=========================|  42 kB    00:00     
---> Package xorg-x11-server-Xorg.i386 0:1.1.1-47.4.fc6 set to be updated
---> Downloading header for dbus-devel to pack into transaction set.
dbus-devel-1.0.1-9.fc6.i3 100% |=========================|  19 kB    00:00     
---> Package dbus-devel.i386 0:1.0.1-9.fc6 set to be updated
--> Running transaction check

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Updating:
 dbus                    i386       1.0.1-9.fc6      updates           471 k
 dbus-devel              i386       1.0.1-9.fc6      updates            38 k
 dbus-x11                i386       1.0.1-9.fc6      updates            28 k
 krb5-devel              i386       1.5-13           updates           1.7 M
 krb5-libs               i386       1.5-13           updates           590 k
 krb5-workstation        i386       1.5-13           updates           887 k
 setup                   noarch     2.6.1.1-1.fc6    updates           126 k
 xorg-x11-server-Xorg    i386       1.1.1-47.4.fc6   updates           3.2 M
 xterm                   i386       223-1.fc6        updates           324 k
 xtide                   i386       2.9-0.2.date20070108.fc6  extras            
633 k
 xtide-common            i386       2.9-0.2.date20070108.fc6  extras            
9.5 k

Transaction Summary
=============================================================================
Install      0 Package(s)         
Update      11 Package(s)         
Remove       0 Package(s)         

Total download size: 8.0 M
Is this ok [y/N]: y
Downloading Packages:
(1/11): dbus-1.0.1-9.fc6. 100% |=========================| 471 kB    00:02     
(2/11): dbus-x11-1.0.1-9. 100% |=========================|  28 kB    00:00     
(3/11): setup-2.6.1.1-1.f 100% |=========================| 126 kB    00:00     
(4/11): xterm-223-1.fc6.i 100% |=========================| 324 kB    00:01     
(5/11): krb5-libs-1.5-13. 100% |=========================| 590 kB    00:02     
(6/11): krb5-workstation- 100% |=========================| 887 kB    00:03     
(7/11): krb5-devel-1.5-13 100% |=========================| 1.7 MB    00:07     
(8/11): xtide-common-2.9- 100% |=========================| 9.5 kB    00:00     
(9/11): xtide-2.9-0.2.dat 100% |=========================| 633 kB    00:02     
(10/11): xorg-x11-server- 100% |=========================| 3.2 MB    00:13     
(11/11): dbus-devel-1.0.1 100% |=========================|  38 kB    00:00     
Running Transaction Test
Segmentation fault
[root@localhost ~]#
Comment 1 Will Woods 2007-01-10 19:06:39 EST

*** This bug has been marked as a duplicate of 222238 ***

Note You need to log in before you can comment on or make changes to this bug.