Bug 222286 - fsck truncates boot sequence if iscsi device is not present and lv placed in /etc/fstab
fsck truncates boot sequence if iscsi device is not present and lv placed in ...
Status: CLOSED DUPLICATE of bug 188657
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: lvm2 (Show other bugs)
4.4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Wysochanski
Corey Marthaler
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-11 09:16 EST by Dave Wysochanski
Modified: 2007-11-16 20:14 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-17 10:21:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Wysochanski 2007-01-11 09:16:22 EST
Description of problem:
I just hit this with LVM2 over iSCSI on RHEL4 U4 (ish).  Boot stops at repair
filesystem prompt until you enter a password.  If you're not at the console or
don't have the console this could be bad.

This problem looks similar:
https://www.redhat.com/archives/linux-lvm/2007-January/msg00017.html


Version-Release number of selected component (if applicable):
# uname -a
Linux gfs1.hpperf.rdu.redhat.com 2.6.9-42.ELsmp-r5 #7 SMP Wed Nov 15 18:48:03
EST 2006 i686 i686 i386 GNU/Linux
[root@gfs1 ~]# lvm version
  LVM version:     2.02.06 (2006-05-12)
  Library version: 1.02.14-cvs (2006-11-28)
  Driver version:  4.5.0


How reproducible:
Every time.


Steps to Reproduce:
1. Create iscsi lun(s) and make an lv with a filesystem
2. Put lv in /etc/fstab with _netdev tag
3. Make sure iscsi service is turned off with checkconfig
4. Reboot
  
Actual results:
Boot stops at filesystem repair prompt.

Expected results:
Boot continues with some warning or error displayed.

Additional info:
Will investigate - might need to check for latest versions.
Comment 1 Dave Wysochanski 2007-01-17 10:21:00 EST

*** This bug has been marked as a duplicate of 188657 ***

Note You need to log in before you can comment on or make changes to this bug.