Bug 222295 - ppp-2.4.3-6.2.1 conflict with syslog on pppoe-server.
ppp-2.4.3-6.2.1 conflict with syslog on pppoe-server.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ppp (Show other bugs)
6
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Nagy
: Patch
Depends On:
Blocks: 443914
  Show dependency treegraph
 
Reported: 2007-01-11 10:07 EST by Alexey Dmitriev
Modified: 2016-07-26 19:46 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-12 05:31:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
closelog() is called early (830 bytes, patch)
2007-11-26 17:57 EST, Ognian Marinov
no flags Details | Diff

  None (edit)
Description Alexey Dmitriev 2007-01-11 10:07:57 EST
Description of problem: I wish to construct pppoe-server on the basis of FC5.
But ppp-2.4.3 has refused to work, works only 2.4.2 or works ppp-2.4.3 with
stopped syslog service

How reproducible:
http://fedoraforum.org/forum/showthread.php?p=713241#post713241
1. /etc/ppp/pppoe-server-options 
----------
# PPP options for the PPPoE server
# LIC: GPL
require-chap
login
lcp-echo-interval 10
lcp-echo-failure 2
proxyarp
ms-dns 168.95.1.1
----------------------
2. use "pppoe-server -I eth1 -S xxx" to initiate the server.  
3. connect from windows with www.raspppoe.com client  - connect not work.
4. execute in console "service syslog stop"
5. connect from windows with www.raspppoe.com client  - connect work.

Actual results:


Expected results:


Additional info:
Comment 1 Andryan Prakasa 2007-02-24 10:00:51 EST
Reproducible on Fedora Core 6.
I tried installing syslog-ng from Fedora Extras, but that didn't fix the problem.
Comment 2 Thomas Woerner 2007-08-30 04:35:22 EDT
Reassigning to FC-6.

Can you please provide the logging output?
Comment 3 Andryan Prakasa 2007-08-30 07:13:48 EDT
Aug 30 18:04:54 pppoe pppoe-server[2147]: Session 3 created for client
00:50:ba:bd:5b:14 (10.67.15.3) on eth0 using Service-Name ''
Aug 30 18:04:54 pppoe pppd[2147]: pppd 2.4.4 started by root, uid 0
Aug 30 18:04:54 pppoe pppd[2147]: Using interface ppp0
Aug 30 18:04:54 pppoe pppd[2147]: Connect: ppp0 <--> /dev/pts/1
Aug 30 18:05:25 pppoe pppd[2147]: LCP: timeout sending Config-Requests
Aug 30 18:05:25 pppoe pppd[2147]: Connection terminated.
Aug 30 18:05:25 pppoe pppd[2147]: Modem hangup
Aug 30 18:05:30 pppoe pppd[2147]: Exit.
Comment 4 Andryan Prakasa 2007-09-15 00:47:38 EDT
Might want to assign this to Fedora 7 as well since this issue also exists in
Fedora 7.
Comment 5 QVirus 2007-11-09 07:01:51 EST
From http://forum.nag.ru/forum/index.php?s=&showtopic=39627&view=findpost&p=285712

small patch:

--- ppp-2.4.4/pppd/main.c.orig 2006-06-04 07:52:50.000000000 +0400
+++ ppp-2.4.4/pppd/main.c 2007-11-09 14:47:20.000000000 +0300
@@ -1567,6 +1567,8 @@
if (errfd == 0 || errfd == 1)
errfd = dup(errfd);

+ closelog();
+
/* dup the in, out, err fds to 0, 1, 2 */
if (infd != 0)
dup2(infd, 0);
@@ -1575,7 +1577,6 @@
if (errfd != 2)
dup2(errfd, 2);

- closelog();
if (log_to_fd > 2)
close(log_to_fd);
if (the_channel->close)
Comment 6 Andryan Prakasa 2007-11-09 08:02:25 EST
Wow, finally a solution.. Thanks!
I hope this issue has been fixed in Fedora 8.
Comment 7 Florin Popovici 2007-11-24 13:13:08 EST
This bug is also present in RHEL/CentOS 5. I suppose the bug really is in
ppp-2.4.3 and 2.4.4, because ppp-2.4.2 works fine.
Comment 8 Ognian Marinov 2007-11-26 17:57:22 EST
Created attachment 269351 [details]
closelog() is called early

I have tested this patch with ppp-2.4.4-2 and rp-pppoe-3.8-1 on Fedora 8.
Everything ran as expected.
Comment 9 Sergei 2008-01-30 07:50:39 EST
Can you explain to me, how to apply this patch, if i have src files???
Comment 10 Martin Nagy 2008-03-12 05:31:05 EDT
Fixed in ppp-2.4.4-6.fc9
Comment 11 Martin Nagy 2008-03-12 05:45:02 EDT
Changing component back to ppp, I have no idea how the heck did it change to
"4suite"
Comment 12 Glenn Baptista 2008-03-14 05:44:36 EDT
(In reply to comment #10)
> Fixed in ppp-2.4.4-6.fc9

Can you provide a download link for the ppp-2.4.4-6 rpm please?
Comment 13 Martin Nagy 2008-03-14 10:49:52 EDT
Check for a mirror near you here: http://mirrors.fedoraproject.org/publiclist
You should click on the rawhide link to filter only repositories with rawhide..
Also know that the file doesn't have to be there at once, it might take a while.

Note You need to log in before you can comment on or make changes to this bug.