Red Hat Bugzilla – 2223050 – The Documentation within "Inventory Upload" in Satellite WebUI redirects to a page which says "This page could not be found"
Note: This bug is displayed in read-only format because
the product is no longer active in Red Hat Bugzilla.
Red Hat Satellite engineering is moving the tracking of its product development work on Satellite to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "Satellite project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs will be migrated starting at the end of May. If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "Satellite project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/SAT-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.
Description of problem:
Accessing Documentation from "Inventory Upload page" on Satellite WebUI redirects to an incorrect URL which results in "This page could not be found" error.
Version-Release number of selected component (if applicable): Satellite 6.14
How reproducible: Always
Steps to Reproduce:
1.Navigate to Satellite WebUI -> Configure -> Inventory Upload page.
2. Click on three vertical dots at top right corner and then click on "Documentation"
Actual results: A new tab is opened where the URL is : "https://access.redhat.com/products/subscription-central%2B" and it says "This page could not be found Back to the home page".
Expected results: The URL of new tab should be "https://access.redhat.com/products/subscription-central/" and it should show valid content instead of "This page could not be found" message.
Additional info: This is reproducible for all Satellite versions
Verified:
Verified with:
- Satellite 6.14.0 snap 10
- rubygem-foreman_rh_cloud-8.0.48-1.el8sat.noarch
Test steps:
- Go to Configure > Inventory Upload.
- Click on the three dots icon, and click on the "Documentation" button.
Observation:
- The user is redirected to "https://access.redhat.com/products/subscription-central/"
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.
For information on the advisory (Important: Satellite 6.14 security and bug fix update), and where to find the updated
files, follow the link below.
If the solution does not work for you, open a new bug report.
https://access.redhat.com/errata/RHSA-2023:6818