Bug 222315 - bluetooth daemons shouldn't be started from an initscript
bluetooth daemons shouldn't be started from an initscript
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: bluez-utils (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Woodhouse
bzcl34nup
:
Depends On:
Blocks: 222312
  Show dependency treegraph
 
Reported: 2007-01-11 11:25 EST by Jeremy Katz
Modified: 2011-04-27 09:00 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-30 11:39:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeremy Katz 2007-01-11 11:25:30 EST
Running the bluetooth daemons on machines without the hardware has little point.
 We should just be starting them when hardware is attached (either as a hal
callout or a udev rule)
Comment 1 David Zeuthen 2007-04-10 18:43:16 EDT
There will be singleton addons in HAL 0.5.10 (Out in 2-3 months) to handle this
- am working with Marcel and other Bluez developers. The only change, for this,
will be replacing the initscript with a HAL fdi file.... 

(there are other Bluez/HAL integration bits that will benefit from this too
(Bluez can claim HAL interfaces) but that is outside the scope of this bug.)
Comment 2 Bastien Nocera 2007-05-08 17:25:19 EDT
David, is there an open bug for that particular HAL feature? It would also be
useful for authentication hardware, so that they could modify the PAM
configuration, and start up helper services on-demand/when plugged in.
Comment 3 David Zeuthen 2007-05-23 16:03:28 EDT
(In reply to comment #2)
> David, is there an open bug for that particular HAL feature? It would also be
> useful for authentication hardware, so that they could modify the PAM
> configuration, and start up helper services on-demand/when plugged in.

It's mentioned here

 http://gitweb.freedesktop.org/?p=hal.git;a=blob;hb=HEAD;f=doc/TODO

and is on track for 0.5.10. HTH.
Comment 4 David Woodhouse 2007-07-21 08:18:23 EDT
Will we have this in time for Fedora 8?
Comment 5 Kostas Georgiou 2007-09-04 21:21:57 EDT
Will it be possible to disable this behaviour? Just because bluetooth hardware
is available it doesn't mean that I always want to run the servers.
Comment 6 Bug Zapper 2008-04-03 14:53:27 EDT
Based on the date this bug was created, it appears to have been reported
against rawhide during the development of a Fedora release that is no
longer maintained. In order to refocus our efforts as a project we are
flagging all of the open bugs for releases which are no longer
maintained. If this bug remains in NEEDINFO thirty (30) days from now,
we will automatically close it.

If you can reproduce this bug in a maintained Fedora version (7, 8, or
rawhide), please change this bug to the respective version and change
the status to ASSIGNED. (If you're unable to change the bug's version
or status, add a comment to the bug and someone will change it for you.)

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.
Comment 7 Jeremy Katz 2008-04-03 15:38:31 EDT
Still the case, still should be fixed
Comment 8 Bug Zapper 2008-05-13 22:33:01 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 9 Bastien Nocera 2008-05-30 11:39:38 EDT
We use dbus activation to start up hcid in rawhide. It probably breaks quite a
few things. Please test and file bugs.
Comment 10 Elad Alfassa 2011-04-27 09:00:36 EDT
Clean F15 install, no bluetooth hardware, and the bluetooth service starts automatically during boot.
Should I file a different bug?

Note You need to log in before you can comment on or make changes to this bug.