Bug 222324 - multilib conflict
multilib conflict
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gdk-pixbuf (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kevin Fenzi
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-11 12:48 EST by Matthias Clasen
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 0_22_0-32_fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-25 22:47:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch (1.97 KB, text/x-patch)
2007-01-11 12:48 EST, Matthias Clasen
no flags Details

  None (edit)
Description Matthias Clasen 2007-01-11 12:48:09 EST
Here is the patch I put in RHEL5 to fix the gdk-pixbuf-config multilib conflict.
It is a little more invasive than the previous two, since gdk-pixbuf did not 
ship a pc file yet.
Comment 1 Matthias Clasen 2007-01-11 12:48:09 EST
Created attachment 145371 [details]
patch
Comment 2 Matthias Clasen 2007-01-11 12:57:10 EST
Forgot to mention that this adds a .pc file, so you'll have to amend the file list.
Comment 3 Kevin Fenzi 2007-01-12 13:54:52 EST
Cool. Thanks very much for the patch. 

I will do some test building here and push this out probibly sometime this 
weekend. 
Comment 4 Kevin Fenzi 2007-01-23 00:05:32 EST
Sorry about the delay here. I finally got around to looking at this. 
This patch attached is the one that provides the pc file... 

It doesn't look to me like there is any multilib conflict right now, at least I 
can install the current i386 and x86_64 versions on the same machine ok.
Were you seeing something else in RHEL5? Or am I misunderstanding the problem?
Comment 5 Matthias Clasen 2007-01-23 00:15:30 EST
The multilib conflict that was reported on RHEL5 occurs because gdk-pixbuf-config
contains the libdir and other arch-dependent paths.
Comment 6 Kevin Fenzi 2007-01-23 00:17:56 EST
Ah ha. Ok, that makes sense then... 

Will do some testing on this and hopefully push it out soon. 
Thanks again for the patch and assistance!
Comment 7 Kevin Fenzi 2007-01-25 22:47:09 EST
ok, pushed out an update with this patch. 
If you spot any problems with it, let me know... 

I am going to close this bug now. Feel free to re-open or file a new one 
if you spot anything else with this package. 

Note You need to log in before you can comment on or make changes to this bug.