Bug 222325 - auto-mounting of, e.g. USB drive, dependent on WM running
auto-mounting of, e.g. USB drive, dependent on WM running
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gnome-volume-manager (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Zeuthen
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-11 12:54 EST by Steve Friedman
Modified: 2013-03-05 22:48 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-20 14:26:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Friedman 2007-01-11 12:54:04 EST
Description of problem:

If I am in runlevel 3, or running a window manager other than gnome (e.g.,
fvwm), and I insert a USB drive, the system detects the hotplug and nearly
completes the automount.  This process only goes to completion if the gnome
window manager is running.

Version-Release number of selected component (if applicable):

udev-095-14

How reproducible:

Every time

Steps to Reproduce:
1. Boot to runlevel 3.
2. Insert USB drive
  
Actual results:
Although /var/log/messages shows that the hotplug detection should have been
able to automount the device (e.g., adding /dev/sdb1), it does not.


Expected results:
The drive mounted in /media/disk, similar to the behavior if gnome was running.

Additional info:
I've been informed that the solution is a simple hack to udev configuration
files such as documented in a Feb 2007 Linux Journal article.  However, I don't
know how that hack will affect the gnome file manager.
Comment 1 Harald Hoyer 2007-09-20 06:40:40 EDT
wont put that in udev. sry
Comment 2 Steve Friedman 2007-09-20 09:28:42 EDT
Then it doesn't belong in udev.  But, if we agree that the *X window manager*
shouldn't determine whether the USB stick is automatically mounted (e.g.,
perhaps it is a server that doesn't have X running), then *please* rather than
closing the bug as WONTFIX please hand it off to the appropriate developer.  I
don't know the internals of your structure, so if udev isn't appropriate forward
it to the group for which it is appropriate -- because it clearly shouldn't be
dependent on which X window manager is running. 
Comment 3 Harald Hoyer 2007-09-20 09:57:39 EDT
this is not the window manager.. this is gnome-volume-manager handling the
"automount" stuff and nautilus using gnome-mount and gnome-umount. KDE has its
own helper applications to do stuff like this.
I don't know if gnome-volume-manager works from text-mode..
Reassigning to gnome-volume-manager, which may give you a hint, what you can do
in text mode.
Comment 4 Steve Friedman 2007-09-20 10:06:14 EDT
I discovered this bug initially because I use fvwm and thus don't utilize
gnome-volume-manager.  However, I would argue that these kinds of low-level
operations belong in an agnostic system package, and not something specific to
gnome, KDE, or what have you.
Comment 5 David Zeuthen 2007-09-20 14:26:10 EDT
This is by design.
Comment 6 Steve Friedman 2007-09-20 16:23:32 EDT
I would love to see the design document that explained why this was the desired
behavior.  But, I guess that since I am not going to code this correctly, I am
stuck with this flaw.
Comment 7 David Zeuthen 2007-09-21 11:47:49 EDT
HAL is only a mechanism and as such don't make policy decisions by itself. The
policy decision to mount something needs to originate from the user session so
it's a) per-user; b) easily configurable without requiring root password to edit
system-wide files

Here's a 50,000 feet presentation detailing how it works.

http://people.freedesktop.org/~david/talks/dynamic-device-handling-OLS-2006.pdf

Good luck.

Note You need to log in before you can comment on or make changes to this bug.