Bug 222349 - (thunderbird-gtk-dand) Dragging messages to folders does not work
Dragging messages to folders does not work
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: thunderbird (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
: Patch
: 225057 226977 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-11 15:17 EST by Karl MacMillan
Modified: 2007-11-30 17:11 EST (History)
17 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-01 08:50:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 367203 None None None Never

  None (edit)
Description Karl MacMillan 2007-01-11 15:17:37 EST
Description of problem:

Dragging individual messages from the subject pane to the folder list no longer
works. The drag starts fine (the cursor changes to show the document) but as
soon as you move the cursor over the folder list a random folder is highlighted
and there is no way to select the desired folder. Dropping seems to have no effect.

Dragging multiple messages works correctly.

Version-Release number of selected component (if applicable):

thunderbird-1.5.0.9-5.fc7

How reproducible:

Always.

Steps to Reproduce:

Drag a single message to a folder in the folders pane.
Comment 1 Leif Hedstrom 2007-01-16 13:09:42 EST
I have the same problem, using latest Rawhide. It started happening a few days
ago, with updates to some Gnome libraries. It also happens with Mozilla
Thunderbird builds, which yum did not update, so I don't think it's a TB problem
directly. It could of course be a TB problem with how it uses the gnome libraries.

Also note that the same problem happens when trying to drag-and-drop folders.
Comment 2 Thorsten Leemhuis 2007-01-19 07:56:22 EST
Confirmed on x86_64 on FC-6 (not devel.i386, as the initial reporter).

IIRC it started suddenly to happen today after logging in and out today. No idea
why. Nothing really changed apart from some updates that got installed in the
past two or three days since the last reboot.
Comment 3 Thorsten Leemhuis 2007-01-19 08:02:05 EST
(In reply to comment #2)
> [...] started suddenly to happen today after logging in and out today. No idea
> why. Nothing really changed apart from some updates that got installed in the
> past two or three days since the last reboot.

Downgrading to gtk2-2.10.4-8.fc6 fixes the problem for me.



Comment 4 Christopher Aillon 2007-01-19 09:53:29 EST
https://bugzilla.mozilla.org/show_bug.cgi?id=367203
Comment 5 Thorsten Leemhuis 2007-01-26 14:41:49 EST
gtk2-2.10.8-1.fc6 now got moved from updates-testing to updates-proper in FC-6.
Thus the bug will show up in FC6 now to -- caillion, I wish you all the best
with closing all the duplicates. I should have been more verbose in #4, maybe
then mclasen would not have pushed that package as proper update for FC-6 :-/ Sorry.

Site note: I talked to wwoods about it. He'll work towards having a red button
to prevent such things in the future. Ohh, and he mentioned that the bug shows
up in firefox, too -- drag and droping of bookmarks does not work anymore :-(
Comment 6 Matthias Clasen 2007-01-26 16:18:26 EST
Can we please try to not get too worked up about this ? 

Remember, the update closed way more bugs than this one regression, which is
caused by totally broken code in the mozilla dnd implementation, not by GTK+.
Comment 7 Matthias Clasen 2007-01-26 16:21:02 EST
I pushed it to final, btw, because i got questions about why those other fixes
were still missing from FC6...
Comment 8 Leif Hedstrom 2007-01-26 19:50:35 EST
Does anyone else have problems with TB crashing for certain events? Like, if I
delete the last bullet in an HTML mail (in composer), or open the "Sent" folder
when it has new stuff in it?

Downgrading GTK solves these problems too, so I'm guessing it's somehow related?
These crashes are much more show-stoppers to me than the lack of drag and drop.
It's bad enough that I have to run TB on a different machine (in order to keep
my "dev" box up on rawhide). If this problems happens with the updates to FC6,
I'd also be concerned.

Cheers,

-- leif
Comment 9 Thorsten Leemhuis 2007-01-27 04:55:23 EST
(In reply to comment #6)
> Can we please try to not get too worked up about this ? 

Can we please try to not break knowingly users systems in a stable release if
there is no need to? A patch seems to be available for tb since more then one
week. Why wasn't it simply applied, tb build and pushed at the same time as the
gtk2 update?

And *if* there is a good reason why that patch was not applied: Why didn't the
gtk update at least contained a hint "Hey, this is known to break drag and drop
in tb, but we shipped the update nevertheless as it fixes a lot of other stuff"
Then people at least know what's up.
Comment 10 Jim Cornette 2007-01-27 09:21:15 EST
This bug also effects seamonkey for development. The right click menu to move
messages works and I have been using that method to move messages instead.
One note: The folder that you are trying to move the message to becomes
highlighted as well as the folder where you are trying to move the message from.
The message stays in the originating location.
Comment 11 Benjamin Thery 2007-01-30 07:46:15 EST
Same problem here with FC6 since I upgraded via yum yesterday (may be latest
GTK2 is the culprit).
This is a real problem for me regarding the number of emails I received
everyday. Sorting them using menu item "Message->Move" is not an acceptable
solution.

Is it possible to reinstall the old GTK2 lib without breaking everyting?
Comment 12 Thorsten Leemhuis 2007-01-30 13:41:18 EST
(In reply to comment #11)
> Is it possible to reinstall the old GTK2 lib without breaking everyting?

Download them manually (e.g. from
http://download.fedora.redhat.com/pub/fedora/linux/core/updates/6/i386/ ) and
install them with "rpm -Uvh foo.rpm --oldpackage"
Comment 13 Matěj Cepl 2007-02-01 04:30:35 EST
(In reply to comment #11)
> This is a real problem for me regarding the number of emails I received
> everyday. Sorting them using menu item "Message->Move" is not an acceptable
> solution.

This is totally workaround and doesn't fix anything. It just may be the way to
survive with your emails -- try https://addons.mozilla.org/firefox/2487/ , it
makes dealing with a lot of mail quite less painful even with broken D&D.
Comment 14 Benjamin Thery 2007-02-01 04:49:42 EST
I rolled back to the previous gtk2 package (gtk2-2.10.4-10.fc6)
as there were no blocking bug for me with this one.
(thanks Thorsten for the --oldpackage option).

I'll also have a look at the TB addons to see if it can help me
with all my emails. :)
Comment 15 Christopher Aillon 2007-02-01 08:50:50 EST
Fwiw, this is fixed in rawhide, and I submitted fc6 updates yesterday.
Comment 16 Matěj Cepl 2007-02-05 05:31:25 EST
*** Bug 226977 has been marked as a duplicate of this bug. ***
Comment 17 Matěj Cepl 2007-02-05 05:34:55 EST
*** Bug 225057 has been marked as a duplicate of this bug. ***
Comment 18 Doug Mitchell 2007-02-07 11:28:51 EST
Fedora Core 6 Updates is still showing 1.5.0.9-2.fc6 as current for me, and I'm
getting other updtes, has this been pushed out?
Comment 19 Benjamin Thery 2007-02-07 11:54:54 EST
Yes, it has been pushed out.
My mirror offers thunderbird-1.5.0.9-7.fc6 
(mirror.kernel.org)

Note You need to log in before you can comment on or make changes to this bug.