Bug 22235 - egcs produces bad .o some time
egcs produces bad .o some time
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: egcs (Show other bugs)
6.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-12-13 11:23 EST by Need Real Name
Modified: 2005-10-31 17:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-02 15:16:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-12-13 11:23:18 EST
I moved from redhat 5.2 to 6.0 and found that I get following error
message:

gcc -DLINUX_RH -D_POSIX_SOURCE -I. -I../linux -I../generic
-I../../../header/linux_rh_60 -I../../../header/linux
-I../../../header/generic -I../../../../../share/linux_rh_60/tps/header
-DCLIENT_BUILD -DDUMB_CLIENT -DSVR4 -D_REENTRANT -D_BSD_SOURCE -c
../generic/error.c -o error.o
.
.
.
ar cq libcscomm.a authorize_client_rpc.o connect_to_rpc_service_rpc.o
login_rpc.o utils_rpc.o get_handle_rpc.o bind_tcp_port_rpc.o
get_tcp_ports_rpc.o register_interface_rpc.o clnt_async.o svc_async.o
csc_socket.o char_descriptor.o error.o csc_platform_utils.o
port_management.o
BFD: error.o: invalid string offset 6912 >= 99 for section `.shstrtab'
BFD: error.o: invalid string offset 8448 >= 99 for section `.shstrtab'
BFD: error.o: invalid string offset 11008 >= 99 for section `.shstrtab'
.
.
.
gcc -o epcommd procedure.o server.o epcommd.o getmount.o parsemnt.o
esl_directory.o direntries.o epcplatform.o rpcsvc.o cluster.o -L.
-L../../../../local_lib/linux_rh_60
-L../../../../../../share/linux_rh_60/esl/lib -L.
-L../../../../csc/fbrowser -Bstatic -lepcomm_api -lepcomm_svc -lcscomm
-lcsc_config_clnt -lcsc_common_clnt -llogging -lesl_utils_c -leerrno
collect2: ld terminated with signal 11 [Segmentation fault], core dumped
/usr/bin/ld: error.o: invalid string offset 6912 >= 99 for section
`.shstrtab'
/usr/bin/ld: error.o: invalid string offset 8448 >= 99 for section
`.shstrtab'
/usr/bin/ld: error.o: invalid string offset 11008 >= 99 for section
`.shstrtab'
.
.
.

The same code if compiled on redhat 5.2 will work fine without any problem.
On 6.0 I first loaded egcs-1.1.2-12 & egcs-c++-1.1.2-12. On seeing the
above problem I then moved to egcs-1.1.2-30 & egcs-c++-1.1.2-30. But this
also did not fix the problem.

On a side note very few times the compilation does go fine without any
problem.  It seems to me that most of the time error.o object in not
generated correctly. I did cmp -l on bad error.o and good error.o and found
that at that difference is of one additional byte. See below:

jain1 66> cmp -l linux_rh_60.bad/error.o linux_rh_60.good/error.o
  7845   0  33
  7846  33   0
  7849   0   1
  7850   1   0
  7853   0   6
  7854   6   0
  7861   0 100
  7862 100   0
  7865   0 262
  7866 262   6
  7867   6   0
  7877   0  20
.
.

Please help as I cannot proceed further. Thanks....
Comment 1 Jakub Jelinek 2000-12-15 11:48:52 EST
This definitely is not compiler issue (error.o is created by assembler),
but it looks like either hardware problem (most probably) or some kernel
corruption issue. I'd suggest you try it on some other hardware or try
some newer kernel (such as from 6.2 distribution).
Comment 2 Need Real Name 2000-12-20 09:23:59 EST
I have the same machine running 5.2 and 6.0. On 5.2 it compiles perfect. Hence
it cannot be a hardware problem.  As far as your suggestion to put 6.2 kernel on
6.0 operating system, I am not sure whether it is really desirable for following
reasons:

1. I want to create my application on 6.0 only so that I can support it for
6.0/6.1/6.2/7.0. I am not sure that after putting 6.2 kernel I would be able to
support 6.0 and 6.1.
2. I see another bug# 5853 reported the similar problem.
3. I installed the 6.0 kernel out of the CDROM provided by redhat. I am sure
that this kernel is not buggy.

Let me know your thoughts. Please give your highest priority to resolve this
issue.
Comment 3 Need Real Name 2001-01-17 16:18:45 EST
I tried on another machine but it gives me the same problem. Please help!!
Comment 4 Jakub Jelinek 2004-10-02 15:16:52 EDT
If you are still able to reproduce this with some current distribution
(FC2 or FC3t2), please reopen.

Note You need to log in before you can comment on or make changes to this bug.