Bug 222402 - RFE: Allow installations into an LV
RFE: Allow installations into an LV
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-11 21:47 EST by Pete Zaitcev
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-15 13:31:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pete Zaitcev 2007-01-11 21:47:40 EST
Anaconda does not allow installations into a logical volume. However,
Xen's backend block drivers allow to have roots on LVs of LVM2.
It would be great if such a configuration was possible to install.
Best of all, while running under Xen.

The issue is, if I select a volume, Anaconda says:
"bootable partitions cannot be at a logical volume"

But in this case, I don't even need to install grub.

Current workaround is to keep a spare partition, install there, then
copy the installation over into the desirable Xen guest's root image.
Comment 1 Jeremy Katz 2007-01-15 13:31:22 EST
Your guest will be using pygrub, though, and pygrub doesn't know how to boot an
LV either.

Note You need to log in before you can comment on or make changes to this bug.