Bug 222424 - anaconda should check & forbid x86_64 upgrades over i386 installs
anaconda should check & forbid x86_64 upgrades over i386 installs
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
:
Depends On:
Blocks: 218571 F8Blocker
  Show dependency treegraph
 
Reported: 2007-01-12 07:52 EST by Răzvan Sandu
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-24 11:48:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Răzvan Sandu 2007-01-12 07:52:20 EST
Description of problem:

Hello,

Since apparently upgrading to x86_64 from an i386 installation gets to a "kernel
panic" situation (please see bug #218571), anaconda should:

- check if this is the case and forbid the upgrade
OR
- manage to perform a clean upgrade in the described situation.

Regards,
Răzvan


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Perform a clean install of Fedora Core 6, i386 version, on 64-bit hardware.
2. Use the x86_64 CD to perform an upgrade over the i386 installation.
3.
  
Actual results:
After reboot, we get a "kernel panic" situation.

Expected results:
Upgrade should get a clean x86_64 OR, if technically not feasible, be forbidden
from the start by anaconda.


Additional info:
Comment 1 Jeremy Katz 2007-01-15 13:32:32 EST
We used to check this but seem to have lost it when moving to using yum as our
backend.
Comment 2 Red Hat Bugzilla 2007-08-21 01:30:47 EDT
User pnasrat@redhat.com's account has been closed
Comment 3 Jeremy Katz 2007-10-22 20:19:45 EDT
Fixed in CVS for Fedora 8
Comment 4 Will Woods 2007-10-24 11:48:38 EDT
Fix is in rawhide. 

Note You need to log in before you can comment on or make changes to this bug.