Bug 222459 - vpnc misses buildrequirements: gcc
vpnc misses buildrequirements: gcc
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: vpnc (Show other bugs)
6
All Linux
medium Severity low
: ---
: ---
Assigned To: Tomas Mraz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-12 11:58 EST by Juha Tuomala
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-15 10:57:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Juha Tuomala 2007-01-12 11:58:38 EST
Description of problem:

Build fails even command:

  yum-builddeb SRPMS/vpnc*

has been executed.

Version-Release number of selected component (if applicable):

0.3.3-13.fc6

How reproducible:

Try to rebuild it in plain system.

Steps to Reproduce:
1. start building in absolute minimal system (RHEL5, fc6)
2. yum-builddeb vpnc-......
3. rpmbuild -bb vpnc.spec
  
Actual results:

build can't find gcc.

Expected results:

finished build.

Additional info:

/me thinks that this level deps should be elsewhere.
Comment 1 Tomas Mraz 2007-01-15 10:57:13 EST
gcc should not be in BuildRequires according to the Fedora packaging guidelines.

http://www.fedoraproject.org/wiki/Packaging/Guidelines#head-4cadce5e79d38a63cad3941de1dadc9d25d67d30
Comment 2 Juha Tuomala 2007-01-15 11:00:24 EST
I agree with the reasoning 'too often', but that anyway causes broken system. 

Those should be rpmbuild pkg dependencies then.
Comment 3 Warren Togami 2007-01-15 11:08:08 EST
Standard build systems like mock have minimal build groups that already satisfy
this desire.  Additionally, you may do it manually by installing rpmdevtools,
which pulls in the minimal requirements as specified by the Fedora Packaging
Guidelines.

Note You need to log in before you can comment on or make changes to this bug.