Bug 222465 - ATA detection and SRST fails on boot for ata3 and ata4 with 82801H controller
ATA detection and SRST fails on boot for ata3 and ata4 with 82801H controller
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-12 12:38 EST by Jonathan Underwood
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: 2.6.19-1.2895
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-13 06:52:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of dmesg after boot (23.40 KB, text/plain)
2007-01-12 12:39 EST, Jonathan Underwood
no flags Details
Output of lspci -vv (14.23 KB, text/plain)
2007-01-12 12:43 EST, Jonathan Underwood
no flags Details

  None (edit)
Description Jonathan Underwood 2007-01-12 12:38:24 EST
Description of problem:
On boot, everything hangs, and messages saying that ata3 and ata4 failed to
respond, and SRST failed. System continues to boot OK. Relevant part from dmesg:
ata3: port is slow to respond, please be patient
ata3: port failed to respond (30 secs)
ata3: SRST failed (status 0xFF)
ata3: SRST failed (err_mask=0x100)
ata3: softreset failed, retrying in 5 secs
ata3: SRST failed (status 0xFF)
ata3: SRST failed (err_mask=0x100)
ata3: softreset failed, retrying in 5 secs
ata3: SRST failed (status 0xFF)
ata3: SRST failed (err_mask=0x100)
ata3: reset failed, giving up

and 

ata4: port is slow to respond, please be patient
ata4: port failed to respond (30 secs)
ata4: SRST failed (status 0xFF)
ata4: SRST failed (err_mask=0x100)
ata4: softreset failed, retrying in 5 secs
ata4: SRST failed (status 0xFF)
ata4: SRST failed (err_mask=0x100)
ata4: softreset failed, retrying in 5 secs
ata4: SRST failed (status 0xFF)
ata4: SRST failed (err_mask=0x100)
ata4: reset failed, giving up

Full dmesg output is attached.

Version-Release number of selected component (if applicable):
kernel-2.6.18-1.2869.fc6 (also seen with the install kernel
kernel-2.6.18-1.2798.fc6). 

How reproducible:
Evertime

Steps to Reproduce:
1.Install FC6
2.
3.
  
Actual results:
ata3 and ata4 not properly detected

Expected results:
ata3 and ata4 properly detected

Additional info:
dmesg output and lspci output will be attached below. What else can I provide to
help debug?
Comment 1 Jonathan Underwood 2007-01-12 12:39:55 EST
Created attachment 145465 [details]
output of dmesg after boot
Comment 2 Jonathan Underwood 2007-01-12 12:43:52 EST
Created attachment 145466 [details]
Output of lspci -vv
Comment 3 Will Woods 2007-01-12 12:53:06 EST
Is there anything attached to ata3/ata4? Are they enabled in the BIOS?

I have a machine here (Dell PowerEdge SC430) that does the same thing with ata2,
which is a SATA port with nothing attached to it. It's disabled in BIOS (as are
ata3 and ata4) but ata_piix still detects it. Strange.
Comment 4 Will Woods 2007-01-12 12:57:46 EST
Oh, my controller's an ICH7-family 82801GB/GR/GH, rev 01 (8086:27c0)
Comment 5 Jonathan Underwood 2007-01-12 13:04:20 EST
Nothing is attached to ata3 and ata4 as far as I can tell.

I just checked in the bios settings:

SATA-2 not available in this chasis
SATA-3 not available in this chasis
SATA-4 Off
SATA-5 Off

Very mysterious.
Comment 6 Will Woods 2007-01-12 13:40:12 EST
This is fixed for me with kernel-2.6.19-1.2895.fc6, which is currently in
updates-testing. Can you enable the updates-testing repo and try that kernel?

(yum --enablerepo=updates-testing update kernel should do it)
Comment 7 Jonathan Underwood 2007-01-13 06:52:25 EST
kernel-2.6.19-1.2895.fc6 does indeed fix the problem for me. I wonder if these
bugs are dupes:

220138
212737

I didn't mark them as dupes, as I wasn't 100 percent sure they are the same thing. 

I'll mark this bug as closed. Thanks for the help.

Note You need to log in before you can comment on or make changes to this bug.