Bug 222490 - media source setting not retained after apply button
media source setting not retained after apply button
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: system-config-printer (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks: FC6Update
  Show dependency treegraph
 
Reported: 2007-01-12 16:22 EST by Andrew
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 0.7.49-1.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-17 12:04:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
HP LaserJet 1320tn PPD (supplied by Fedora) from problematic system (56.99 KB, application/octet-stream)
2007-01-15 12:21 EST, Andrew
no flags Details

  None (edit)
Description Andrew 2007-01-12 16:22:31 EST
Description of problem:
Under printer options, I set the media source to tray 3.  After clicking apply,
the setting changes to tray 1 or tray 2.

Version-Release number of selected component (if applicable):
system-config-printer-0.7.32-1
system-config-printer-0.7.45-1.fc6

How reproducible:
Always---on three Fedora Core 6 systems.

Steps to Reproduce:
1. Setup an HP LaserJet 1320tn using JetDirect socket and "PostScript
(recommended)".
2. Click on "installable options."
3. Enable tray 2 and 3.
4. Click on "printer options."
5. Change "media source" to "tray 3."
6. Click "apply" button.

Actual results:
The media source changes to 1 or 2.  (Only one of my three machines goes to tray 2.)

Expected results:
EITHER
1. The selected option stays, or
2. There is a friendly error pop-up message explaining the change.

Additional info:
Comment 1 Tim Waugh 2007-01-15 10:23:22 EST
I can't reproduce this.  Please supply the PPD you are using (from /etc/cups/ppd).
Comment 2 Andrew 2007-01-15 12:20:59 EST
After I deleted and recreated the printer, I also could not reproduce the
problem.  Perhaps creating the printer with the earlier version of the
system-config-printer software was the problem.
Comment 3 Andrew 2007-01-15 12:21:57 EST
Created attachment 145590 [details]
HP LaserJet 1320tn PPD (supplied by Fedora) from problematic system
Comment 4 Tim Waugh 2007-01-15 13:32:29 EST
To reproduce:

Enable 'Tray 3' in Installable Options
Select 'Tray 3' for Media Source in Printer Options
Enable 'Tray 1 (Manual)' in Printer Options

This is happening because we set the ManualFeed ('Tray 1 (Manual)') option after
the InputSlot ('Media Source') option, and CUPS treats these options specially
(in the ppdMarkOption() function).

I think this might need special treatment in the UI.
Comment 5 Fedora Update System 2007-01-17 11:25:47 EST
Fixed in update: system-config-printer-0.7.49-1.fc6

Note You need to log in before you can comment on or make changes to this bug.