Bug 222509 - handle updating of ~/.xmms/config safely
Summary: handle updating of ~/.xmms/config safely
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: xmms   
(Show other bugs)
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Paul F. Johnson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-13 00:37 UTC by Sami Farin
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-18 23:01:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
update ~/.xmms/config safely (1.80 KB, patch)
2007-01-13 00:37 UTC, Sami Farin
no flags Details | Diff

Description Sami Farin 2007-01-13 00:37:59 UTC
Description of problem:
xmms writes ~/.xmms/config in a not-so-safe-way.
when xmms crashes or system blows up while xmms is writing config file,
on next xmms startup you are probably left with empty/invalid config file.

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. save config
2. have bad luck
3.
  
Actual results:
~/.xmms/config contains garbage or is empty

Expected results:
~/.xmms/config having earlier contents prior to crash

Additional info:
playlist seems to be written badly, too, but that's another issue...
in case someone cares.

Comment 1 Sami Farin 2007-01-13 00:38:00 UTC
Created attachment 145507 [details]
update ~/.xmms/config safely


Note You need to log in before you can comment on or make changes to this bug.