Bug 222520 - PIT handler wrongly registered to dom0
Summary: PIT handler wrongly registered to dom0
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel-xen   
(Show other bugs)
Version: 5.0
Hardware: All
OS: Linux
high
high
Target Milestone: ---
: ---
Assignee: Rik van Riel
QA Contact:
URL:
Whiteboard:
Keywords: Regression
: 223264 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-13 04:15 UTC by Herbert Xu
Modified: 2007-11-30 22:07 UTC (History)
3 users (show)

Fixed In Version: 5.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-26 21:32:00 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Register PIT handlers to the correct domain (5.51 KB, patch)
2007-01-13 04:15 UTC, Herbert Xu
no flags Details | Diff

Description Herbert Xu 2007-01-13 04:15:04 UTC
Due to an early patch (backport of upstream changeset 13028), the PIT handlers
for HVM guests ended up getting registered to dom0.  This causes two problems:

1) The HVM guest doesn't work because there is no PIT IO handler.
2) dom0 eventually dies because all its IO handler slots are consumed (there are
only 8 to start with).

This is a reduced version of upstream changeset 12243 that fixes the problem.

Comment 1 Herbert Xu 2007-01-13 04:15:04 UTC
Created attachment 145517 [details]
Register PIT handlers to the correct domain

Comment 4 Jay Turner 2007-01-15 15:25:22 UTC
QE ack for RHEL5 and setting the proposed blocker flags, as there's really no
way to ship without fixing this.

Comment 6 Don Zickus 2007-01-16 21:38:31 UTC
in 2.6.18-2.el5

Comment 7 Jan Pazdziora 2007-01-17 10:49:42 UTC
Is this patch supposed to have some effect on paravirtualized guests? I've seen
my dom0 reboot occasionally since upgrading to 2.6.18-1.3002.el5xen, and with
2.6.18-2.el5xen I had no crashes yet, but I wonder if it's just luck or if the
code could have fixed paravirt as well.

Comment 8 Herbert Xu 2007-01-17 11:24:48 UTC
Yes it does affect PV as well, albeit partially.  It doesn't prevent PV guests
from functioning (although the PIT handler won't be completely functional).  The
part where dom0's IO handlers fill up definitely will occur for all guests
regardless of whether they're PV or FV.

Comment 9 Daniel Berrange 2007-01-18 21:47:38 UTC
*** Bug 223264 has been marked as a duplicate of this bug. ***

Comment 10 Jan Pazdziora 2007-01-22 10:52:59 UTC
Herbert, thanks. The 2.6.18-2.el5xen is definitely more stable for PV then
2.6.18-1.3002.el5xen.

Comment 11 Jay Turner 2007-01-26 21:32:00 UTC
2.6.18-7.el5 included in 20070125.0.


Note You need to log in before you can comment on or make changes to this bug.