Bug 222527 - python exception in Software Installer
python exception in Software Installer
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-13 06:41 EST by Herbert Carl Meyer
Modified: 2014-01-21 17:56 EST (History)
0 users

See Also:
Fixed In Version: fc6updates
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-09 16:42:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Herbert Carl Meyer 2007-01-13 06:41:33 EST
Description of problem:
python exception in Software Installer

Version-Release number of selected component (if applicable):
unk

How reproducible:
don't know

Steps to Reproduce:
1. use software installer from firefox, install azereus client
2. download vmware player rpm to disk
3. run software installer from nautilus on vmware player
  
Actual results:

exception in software installer, traceback:

Component: Software Installer
Summary: TBdae920e4 plugins.py:475:getPackages:AttributeError: 'NoneType' object
has no attribute 'returnPackages'

Traceback (most recent call last):
  File "/usr/sbin/system-install-packages", line 204, in _apply
    self.applyChanges(self.mainwin)
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 559, in
applyChanges
    self.checkDeps(mainwin)
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 328, in checkDeps
    (result, msgs) = self.buildTransaction()
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 442, in
buildTransaction
    self.plugins.run('postresolve', rescode=rescode, restring=restring)
  File "/usr/lib/python2.4/site-packages/yum/plugins.py", line 153, in run
    func(conduitcls(self, self.base, conf, **kwargs))
  File "/usr/lib/yum-plugins/kmdl.py", line 103, in postresolve_hook
    kmdl_install(conduit, kernels, kmdls(conduit))
  File "/usr/lib/yum-plugins/kmdl.py", line 82, in kmdl_install
    for pkg in conduit.getPackages():
  File "/usr/lib/python2.4/site-packages/yum/plugins.py", line 475, in getPackages
    return self._base.pkgSack.returnPackages(arg)
AttributeError: 'NoneType' object has no attribute 'returnPackages'

Local variables in innermost frame:
repo: None
self: <yum.plugins.DepsolvePluginConduit instance at 0x9a8ee2c>
arg: None

Expected results:
install software

Additional info:
Included details because it was the second time software installer run during
session, possible stale locks ?

Side effect seemed to be knocking out gnome panel and menu system, reboot needed.

Oh yeah, add Sofware-Instller to component dropdown in BZ, this bug is entered
against yum.
Comment 1 Jeremy Katz 2007-01-15 13:19:39 EST
Which yum plugins do you have installed?
Comment 2 Herbert Carl Meyer 2007-01-17 15:56:46 EST
installonyn and axel's kmdl
Comment 3 Jeremy Katz 2007-04-09 16:42:56 EDT
This is a bug in the kmdl plugin, but current releases of yum and the plugin
should be happier.

Note You need to log in before you can comment on or make changes to this bug.