This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 222540 - --append option not working in usermod
--append option not working in usermod
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: shadow-utils (Show other bugs)
6
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Vrabec
David Lawrence
:
Depends On:
Blocks: 578746
  Show dependency treegraph
 
Reported: 2007-01-13 12:01 EST by Michael De La Rue
Modified: 2010-04-01 05:06 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 578746 (view as bug list)
Environment:
Last Closed: 2007-01-14 08:39:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
actual session showing usermod failing to work (2.00 KB, text/plain)
2007-01-13 12:01 EST, Michael De La Rue
no flags Details

  None (edit)
Description Michael De La Rue 2007-01-13 12:01:19 EST
Description of problem:
The --append long option does not seem to work at all.  The equivelent -a option
does work.  I'm leaving this as normal severity rather than low

Version-Release number of selected component (if applicable):
Version     : 4.0.17
Release     : 11.fc6 

How reproducible:
every time

Steps to Reproduce:
1. groupadd -r sound 
2. usermod -a -G sound mikedlr
3. usermod --append -G sound mikedlr
4. usermod -a -G sound mikedlr  

Actual results:
the second and fourth command complete correctly and silently.  The third step
outputs the usage information from usermod 

Expected results:
according to manual page and usermod --help, --append option should do the same
as -a

Additional info:
I'm leaving this as normal severity since an important script might be depending
on this.
Comment 1 Michael De La Rue 2007-01-13 12:01:19 EST
Created attachment 145529 [details]
actual session showing usermod failing to work
Comment 2 Peter Vrabec 2007-01-14 08:39:00 EST
fixed in shadow-utils-4.0.17-12.fc6

Note You need to log in before you can comment on or make changes to this bug.