Bug 2225402
| Summary: | Associating a host with an VM with added "Precision Clock Device" on Satellite fails with error unknown VMODL type VirtualPrecisionClock | ||
|---|---|---|---|
| Product: | Red Hat Satellite | Reporter: | Jayant Bhatia <jbhatia> |
| Component: | Compute Resources - VMWare | Assignee: | satellite6-bugs <satellite6-bugs> |
| Status: | CLOSED ERRATA | QA Contact: | sganar |
| Severity: | medium | Docs Contact: | |
| Priority: | medium | ||
| Version: | 6.11.0 | CC: | ahumbe, chrobert, gtalreja, lstejska, mhulan, rlavi, saydas, shwsingh |
| Target Milestone: | 6.14.0 | Flags: | rlavi:
needinfo?
|
| Target Release: | Unused | ||
| Hardware: | Unspecified | ||
| OS: | Unspecified | ||
| Whiteboard: | |||
| Fixed In Version: | Doc Type: | If docs needed, set a value | |
| Doc Text: | Story Points: | --- | |
| Clone Of: | Environment: | ||
| Last Closed: | 2023-11-08 14:20:07 UTC | Type: | Bug |
| Regression: | --- | Mount Type: | --- |
| Documentation: | --- | CRM: | |
| Verified Versions: | Category: | --- | |
| oVirt Team: | --- | RHEL 7.3 requirements from Atomic Host: | |
| Cloudforms Team: | --- | Target Upstream Version: | |
| Embargoed: | |||
|
Description
Jayant Bhatia
2023-07-25 08:53:31 UTC
Reproducer steps shared by the end-user : New virtual machine: 1. Create New Virtual Maschine (From vSphere Web-Client) Guest OS Family: Linux Guest OS Version: Red Hat Enterprise Linux 8 (64-bit) Compatibility: ESXi 7.0 U2 and later Customize hardware -> Add new device -> Precision CLock (Host System Time NTP) -> Build VM 2. Create Host (From RH Satellite) 3. Compute Resources -> Virtual Maschines -> Associate VM ---> Results in error: "Oops, we're sorry but something went wrong unknown VMODL type VirtualPrecisionClock" Existing virtual machine: Modify hardware ((From vSphere Web-Client)) 1. Add new device -> Precision CLock (Host System Time NTP) 2. All hosts -> VM Hostname -> Edit ---> Results in error: "Oops, we're sorry but something went wrong unknown VMODL type VirtualPrecisionClock" Verified. Tested on Satellite 6.14.0 Snap 21.0 rubygem-rbvmomi2-3.6.1-1.el8sat.noarch Steps followed: 1. Create a VMware CR 2. Go to Infrastructure > Compute Resources > select the created CR > Virtual machines 3. Select Import as managed host > disassociate host and try to Associate VM Observation: Everything works perfectly. No issues were observed while associating or importing the VM. Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. For information on the advisory (Important: Satellite 6.14 security and bug fix update), and where to find the updated files, follow the link below. If the solution does not work for you, open a new bug report. https://access.redhat.com/errata/RHSA-2023:6818 |