Bug 222544 - all_interfaces.conf:7820:ERROR 'syntax error' at token 'allow'
all_interfaces.conf:7820:ERROR 'syntax error' at token 'allow'
Status: CLOSED DUPLICATE of bug 222548
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Ben Levenson
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-13 14:00 EST by Mace Moneta
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-15 10:51:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mace Moneta 2007-01-13 14:00:32 EST
Description of problem:

After applying selinux-policy-targeted.noarch 2.4.6-23.fc6 and
selinux-policy-devel.noarch 2.4.6-23.fc6, attempting to set a local policy
results in:

# cd /etc/local-selinux-policy/
# /usr/bin/make -f /usr/share/selinux/devel/Makefile
Compiling targeted local module
/usr/bin/checkmodule:  loading policy configuration from tmp/local.tmp
tmp/all_interfaces.conf:7820:ERROR 'syntax error' at token 'allow' on line 3871:

allow staff_evolution_alarm_t staff_t:fifo_file { getattr write };
/usr/bin/checkmodule:  error(s) encountered while parsing configuration
make: *** [tmp/local.mod] Error 1


Version-Release number of selected component (if applicable):

selinux-policy-targeted.noarch 2.4.6-23.fc6 and selinux-policy-devel.noarch
2.4.6-23.fc6

How reproducible:

Always

Steps to Reproduce:
1. /usr/bin/make -f /usr/share/selinux/devel/Makefile
2. observe error
3.
  
Actual results:

tmp/all_interfaces.conf:7820:ERROR 'syntax error' at token 'allow' on line 3871:

allow staff_evolution_alarm_t staff_t:fifo_file { getattr write };
/usr/bin/checkmodule:  error(s) encountered while parsing configuration
make: *** [tmp/local.mod] Error 1

Expected results:

No error

Additional info: This happens on all the systems I have (both x86 and x86_64).
Comment 1 Daniel Walsh 2007-01-15 09:11:04 EST
This is a compiling/source code problem.  Not a bug.  Please bring your question
to one of the public list.
Comment 2 Mace Moneta 2007-01-15 09:35:42 EST
I'm sorry, but that's not the case.

Even with an empty local policy, the error still occurs, which indicates that
the distributed source policy is in error.
Comment 3 Daniel Walsh 2007-01-15 10:51:54 EST
Ok now I see.  This is fixed in selinux-policy-2.4.6-27

*** This bug has been marked as a duplicate of 222548 ***

Note You need to log in before you can comment on or make changes to this bug.