Bug 22255 - Install problems on Toshiba 3480CT
Install problems on Toshiba 3480CT
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
7.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Erik Troan
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-12-13 12:34 EST by Need Real Name
Modified: 2007-04-18 12:30 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-12 14:10:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-12-13 12:34:33 EST
I am trying to install RedHat 7 on a Toshiba 3480CT laptop.
This has a 12GB IDE disk as /dev/hda1.  It has no internal
CD but I have a PCMCIA ATAPI CD drive,  from which it can
boot.  It has no internal floppy,  but it does have an
external USB floppy,  with BIOS emulation of a regular
floppy which allows it to boot.  Using Windows 2K,  I copied
the contents of the RH7 CD to the directory c:\tmp\redhat on
the FAT32 file system on c.

Each route I have tried to install seems blocked:

1)      Boot & install from CD.

        I boot the system "expert" and get to the "Installation
        Method" dialog.  I chose "Local CDROM" and get the "CDROM
        type" dialog with choices "SCSI" or "Other CDROM".
        Choosing "other" asks for a driver disk.  Even if I had
        one it would be a floppy,  and Ctrl-Alt-F4 screen shows
        that although it loaded usb & usb-uhci,  and found a
        device on the USB bus (the floppy is the only device)
        the kernel doesn't recognize it.

2)      Boot from PCMCIA floppy, install from CD.

        I boot the system "expert" and get the "PC Card" box - at
        this point the CD spins up.  The Ctrl-Alt-F4 screen shows
        that cardmgr came up,  recognized an ATA/IDE Fixed Disk in
        socket 0,  and executed modprobe ide_cs.o.  hdc was assigned
        to the ATAPI CDROM drive and there is a message "Uniform
        CD-ROM driver Revision 3.10".  Then ide_cs says hdc: Vcc = 5.0,
        Vpp = 12.0.  Then cardmgr says "fopen(stabfile) failed: %m" and
        exits.

        Going back to the install,  I say "no" to the "Devices" question
        about whether I have a driver disk (because even if I did the
        floppy drive is USB).  Then I get to the "Installation Method"
        dialog and only have "Hard drive" as a choice - the system fails
        to realize it has an ATAPI CD via the PCMCIA slot.

        [NB - if I boot "linux rescue" and tell it the RPMs and stuff
        are on the hard disk,  I can use the rescue system to mount and
        access the PCMCIA CD].

3)      Boot from PCMCIA floppy or CD,  install from hard disk.

        I boot the system "expert" and say "no" each time it asks for
        a driver disk.  I choose "Hard disk" from the "Installation
        Method" dialog and "Custom System" from the "Installation
        Type" dialog. I use Disk Druid to ask for a partitionless
        install,  with 2000 MB for the root and 128MB for swap.  I
        choose generic 2-button mouse with 3-button emulation and
        set the time zone.  I do the user setup and choose a set of
        package groups totalling 785MB.  I choose "S3 Savage (generic)"
        because the 3480CT has an 8MB S3 Savage/IX.

        After a while,  an "Exception Occurred" dialog appears.  The
        problem is in trying to open /mnt/loophost/redhat.img for the
        very good reason that it doesn't exist (/mnt/loophost/rh-swap.img
 does exist and appears to be the requested size).
Comment 1 Michael Fulbright 2000-12-13 14:59:29 EST
Assigning to a developer.
Comment 2 Erik Troan 2000-12-19 18:05:29 EST
#3 is the only option for you in 7.0 (the next release will work better);
however, could you send the contents of that traceback?
Comment 3 Need Real Name 2001-01-01 11:14:54 EST
Here's the traceback:

438     /usr/bin/anaconda.real  intf.run(todo, test = test)
1030    /var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py in run
507     /var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py in __call__
1472    /var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py in doInstall
703     /var/tmp/anaconda-7.0.1//usr/lib/anaconda/fstab.py in mountFilesystems
46      /usr/lib/anaconda/isys.py in losetup
        targ = os.open(file, mode)
OSError: [Errno 2] No such file or directory : '/mnt/loophost/redhat.img'
Comment 4 Need Real Name 2001-01-01 11:26:00 EST
I figured out another possible way to do the install.

The 3480CT has an Intel EtherPro 100 on-board Ethernet interface.
So I created a bootnet floppy,  booted it and tried the same partitionless
install from ftp://sunsite.utk.edu/

This time it got a lot further.  It created, mounted the
/mnt/loopback/sysimage file system,  filled it with packages
from the FTP server, and stopped at the point where it was
trying to create a boot floppy on /dev/fd0,  which doesn't
really exist as the machine has a USB floppy.

It looks probable that I can do a native install (not partitionless)
using the bootnet floppy.  This will install LILO and will not
need to use the USB floppy after the initial boot.  I will do this as
soon as I have confirmed that I can use the Toshiba-supplied
system restore CDs to get a working Win2K system back if the
install goes wrong.
Comment 5 Need Real Name 2001-01-01 11:30:29 EST
One more note.  The Intel EtherPro 100 driver module on the bootnet
floppy can only be inserted successfully if the patch cord is not
plugged in.  Once it has been inserted the cord can be connected
and everything works.  This should probably be a separate bug ...
Comment 6 Erik Troan 2001-01-12 14:10:54 EST
The other problems you ran into (including the nonworking PCMCIA IDE CDROM) have
been, or are being addressed. Since you can do a network install, I'm going to
close this bug.

Note You need to log in before you can comment on or make changes to this bug.