Bug 222553 - kernel BUG at mm/slab.c:594 when making Nokia E50 "PC Suite" connection
kernel BUG at mm/slab.c:594 when making Nokia E50 "PC Suite" connection
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2007-01-13 20:09 EST by Mads Kiilerich
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: 2.6.20-1.2944.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-04-17 17:33:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
dmesg after crash (15.51 KB, text/plain)
2007-01-13 20:09 EST, Mads Kiilerich
no flags Details
dmesg after nokia e50 has been plugged in and the dust has settled (24.33 KB, text/plain)
2007-01-13 21:48 EST, Paul Witt
no flags Details

  None (edit)
Description Mads Kiilerich 2007-01-13 20:09:04 EST
Description of problem:
kernel BUG at mm/slab.c:594 when making Nokia E50 "PC Suite" connection

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Connect Nokia e50 using USB cable
2. Choose PC Suite
3. BUG
Actual results:
see attached dmesg with:
drivers/usb/class/cdc-acm.c: v0.25:USB Abstract Control Model driver for USB
modems and ISDN adapters
usbcore: registered new driver cdc_ether
rndis_host 1-2:1.12: RNDIS init failed, -32
usb%d: unregister 'rndis_host' usb-0000:00:02.0-2, RNDIS device
unregister_netdevice: device usb%d/eb183800 never was registered
------------[ cut here ]------------
kernel BUG at mm/slab.c:594!
invalid opcode: 0000 [#1]

Expected results:
no crash - and perhaps something good happening automatically

Additional info:
Probably the same as http://lkml.org/lkml/2006/12/11/183 - but I can't find out
if the problem was solved...
Same BUG report, but seems to be something else:
Comment 1 Mads Kiilerich 2007-01-13 20:09:04 EST
Created attachment 145536 [details]
dmesg after crash
Comment 2 Paul Witt 2007-01-13 21:48:17 EST
Created attachment 145538 [details]
dmesg after nokia e50 has been plugged in and the dust has settled
Comment 3 Paul Witt 2007-01-13 21:54:15 EST
I've just posted my dmesg as an attachment.  Note I'm running 2.6.18-1.fc6,
which I believe is currently the latest.  I only decided to start playing with
this phone today, though, so I'm not sure how long ago the bug was introduced
into the kernel.  No "external" kernel modules are being loaded here.

Not sure if this makes any difference, but this is on a Thinkpad T40 which has
intel EHCI USB2 controllers.

I was playing with the same phone on a RHEL system earlier today, and what is
supposed to happen is:

 - the system sees a USB hub and the Nokia phone on that hub
 - a device /dev/ttyACM0 is created, through which you can do everything you
would want to do
Comment 4 Paul Witt 2007-01-13 22:10:39 EST
I forgot to mention: it's a dku-2 cable and the software on the phone is series 60
Comment 5 Bryn M. Reeves 2007-04-17 06:47:10 EDT
This sounds like bug 228231 that was fixed in 2.6.19-1.2911.6.3. Can you re-test
with a later FC6 kernel and update this bugzilla if you are still having problems?

Comment 6 Mads Kiilerich 2007-04-17 17:28:28 EDT
I can confirm that I don't get crash with 2.6.20-1.2944.fc6.

(I haven't been able to get any connection to the phone yet, but that is
probably the operators fault.)

I consider the issue solved. Thanks.

Note You need to log in before you can comment on or make changes to this bug.