Bug 222560 - hp-check fails with traceback
hp-check fails with traceback
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: hplip (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks: FC6Update
  Show dependency treegraph
 
Reported: 2007-01-14 05:16 EST by Tim Wegener
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 1.6.12-1.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-22 12:51:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch for /usr/share/hplip/check to solve problem (700 bytes, patch)
2007-01-14 05:16 EST, Tim Wegener
no flags Details | Diff

  None (edit)
Description Tim Wegener 2007-01-14 05:16:10 EST
Description of problem:


Version-Release number of selected component (if applicable):
hplip-1.6.10-1.fc6.4

How reproducible:
Always

Steps to Reproduce:
1. hp-check
  
Actual results:
----------------------
| INSTALLED PRINTERS |
----------------------


Photosmart_C4100_series
-----------------------
Device URI:
hal:///org/freedesktop/Hal/devices/usb_device_3f0_5711_MY65CB919404J7_if1_printer_MY65CB919404J7
Installed in HPLIP? No
PPD: /etc/cups/ppd/Photosmart_C4100_series.ppd
PPD Description: HP PhotoSmart C4100 Foomatic/hpijs (recommended)

Printer status:
printer Photosmart_C4100_series is idle.  enabled since Sun 14 Jan 2007 07:11:04
PM CST

Traceback (most recent call last):
  File "/usr/bin/hp-check", line 285, in ?
    if back_end == 'hpfax' and desc != 'HP Fax':
NameError: name 'back_end' is not defined

Expected results:
Rest of script to be run with normal clean exit.

Additional info:
Patch for /usr/share/hplip/check attached.
Comment 1 Tim Wegener 2007-01-14 05:16:10 EST
Created attachment 145542 [details]
Patch for /usr/share/hplip/check to solve problem
Comment 2 Tim Waugh 2007-01-15 09:20:51 EST
Looks like this is already fixed in the 1.6.12-1.fc6 updates-testing package.
Comment 3 Fedora Update System 2007-01-22 12:01:23 EST
Fixed in update: hplip-1.6.12-1.fc6

Note You need to log in before you can comment on or make changes to this bug.