This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 222568 - Kadischi - A first experience
Kadischi - A first experience
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kadischi (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chitlesh GOORAH
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-14 12:58 EST by Bob Gustafson
Modified: 2013-01-09 23:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-07 18:20:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bob Gustafson 2007-01-14 12:58:27 EST
Description of problem:

I stepped through the process, substituting FC6 and filling in the
        blanks with logical if not useful phrases.
        

        And, it worked! (at least I burned a CD..). The last step was a little
        ragged:
        
                [kadischi]: Kadischi is finished building the Live ISO image..
                [kadischi]: Would you like to burn the CD image now? [yes/no]:
                yes
                [kadischi]: What device is your CDROM or DVDROM? [/dev/cdrom]: 
                /usr/bin/cdrecord: No tracks specified. Need at least one.
                Usage: /usr/bin/cdrecord [options] track1...trackn
                
                Use     /usr/bin/cdrecord -help
                to get a list of valid options.
                
                Use     /usr/bin/cdrecord blank=help
                to get a list of valid blanking options.
                
                Use     /usr/bin/cdrecord dev=b,t,l driveropts=help -checkdrive
                to get a list of drive specific options.
                
                Use     /usr/bin/cdrecord dev=help
                to get a list of possible SCSI transport specifiers.
                [kadischi]: cdrecord not found or other error! Bailing!
                
        
        But I was able to burn a CD manually from the iso that was sitting
        in /tmp.
        
        Congrats.
        
        Bob G
==== subsequent experience ====

The cd was built on a desktop and then run it on an old Gateway Solo 2150 that
has problems:

[The Solo does not seem to see the hard disk on boot, even though I can install
Fedora6 from cd to the hard disk.  Attempting to boot using a boot floppy -
accepts root and kernel lines, but complains about initrd being wrong. This was
the motivation to burn my own livecd - Google lead me to Kadischi]

Sticking the kadischi liveCD into the Solo 2150, it comes up reasonably well,
although there are numerous files that it cannot find during the boot. Finally,
it comes to the 'login' screen. Unfortunately, it did not know any of the user1
and/or root passwords that I gave it.

I saw the note on the LiveCD FAQ page that the passwords for root are possibly
not what I keyed in. I tried them all and still cannot log into the Solo 2150.

===== Second try ====

I went back to the desktop machine and instead of using the http:// repository,
I mounted the FC6 DVD on /mnt/cdrom and used the command line:

[root@hoho2 ~]# kadischi /mnt/cdrom /tmp/fedora-live2.iso

The hd:// and file:// methods don't work. Just putting in the FC6 DVD mount
point did the trick.

I was careful typing in a root password and I wrote it down.

The on-screen GUI process ends in a window asking to REBOOT. I did click, but
was worried that it would reboot my build machine (which it did not).

In fact, the kadischi process continued in a text (curses) mode, asking for
firewall approval (couldn't turn off firewall..) and then users. I carefully
added a couple of users and passwords. The password acceptance was weird though
- it complained that I was using a dictionary word (which I was not) and then
seemed to accept the second keying of (hopefully) the same password.

It is compressing now.. (The compression could be faster if it used more
processors..)

====
Booting this second CD on the Solo, I see lines complaining that it cannot find
/livecd/tmpfs/tmp

Then I got to the 'login' command line, but before I could try my new usernames
and passwords, I got a (curses) dialog box that said:

The GDM group 'gdm' does not exist. Please correct GDM configuration and restart
GDM. <ok>

I don't think I did anything differently between the first CD burn and the
second except for putting in more usernames and passwords (and using the FC6
install DVD instead of the http:// repository).

If this jogs anyone's memory, please post. In the meantime I will look around
here for my R/W cd's.

Version-Release number of selected component (if applicable):

[root@hoho2 ~]# kadischi --version
[kadischi]: Checking dependencies for Kadischi
[kadischi]: Checking UID for root access
[kadischi]: Starting kadischi with root access...
kadischi.py 2.5
[root@hoho2 ~]# 

How reproducible:

Different results both tries (but with different inputs..)

Steps to Reproduce:
see above
1.
2.
3.
  
Actual results:
see above


Expected results:

A running Solo 2150

Additional info:
Comment 1 Jasper O. Hartline 2007-04-23 08:05:07 EDT
Can you please try Kadischi from CVS as of today, April 23rd 2007 and report any
more mishaps or bugs, and define them specifically.
Comment 2 Chitlesh GOORAH 2007-07-07 18:20:04 EDT
Kadischi's development has stalled for a long time now.
There is no one to lead this project.

I'm therefore closing all open bugs related to kadischi as WONTFIX.

However I recommend you do try "revisor" to create your custom spins.
On Fedora 7, you can install revisor with:

yum install revisor

as root.

Note You need to log in before you can comment on or make changes to this bug.