Bug 222587 - gnome-applets-2.16.0.1-13.fc6 Power manager GConf schema installer error, desktop settings all messed up
gnome-applets-2.16.0.1-13.fc6 Power manager GConf schema installer error, des...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: gnome-applets (Show other bugs)
6
All Linux
medium Severity high
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-14 16:08 EST by Charles R. Anderson
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-05 17:57:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Charles R. Anderson 2007-01-14 16:08:20 EST
Description of problem:
Installing the latest gnome-applets-2.16.0.1-13.fc6 from updates-testing causes
major issues with the desktop.  None of the gnome settings appear to load upon
login.  The desktop background doesn't load, the panel doesn't load, none of the
applets load, no pager appears.  There is no Fedora menu, and none of the
hotkeys work (alt-f2, alt-tab, etc.) so this is a difficult situation to cope
with.  I had to navigate to /usr/bin with Nautilus in order to double click
xterm to get a way to launch applications.  The following dialog box pops up:

Power Manager
GConf schema installer error.
battery_low_percentage cannot be zero

After downgrading to gnome-applets-2.16.0.1-12.fc6, the problem goes away, but
any accounts that had logged in with 2.16.0.1-13.fc6 installed have their gconf
settings all pooched now, with the theme settings gone, no panel, no Fedora
menu, etc.  Deleting .gconf* fixes the issue, but of course all settings are
back to defaults.

Version-Release number of selected component (if applicable):
2.16.0.1-13.fc6

How reproducible:
always

Steps to Reproduce:
1. install gnome-applets-2.16.0.1-13.fc6
2. log into gnome with a brand new throw-away account
3. all desktop settings are gone, panel is gone, no pager or other applets
  
Actual results:

Desktop loads, but the theme is gone.  There is no desktop background (black
desktop), no gnome panel, no pager, no panel applets.  The following dialog box
pops up:

Power Manager
GConf schema installer error.
battery_low_percentage cannot be zero

Expected results:
The desktop should be usable and the settings should not be all messed up.

Additional info:
Comment 1 Ray Strode [halfline] 2007-01-15 10:07:11 EST
Hi Charles,

Would you mind reconfirming that installing the updated gnome-applets package is
the trigger for this bug?  I'm asking because I just looked through the diff of
the last change of gnome-applets and it was only a one line change to an applet
that's not normally in a users configuration.

Were there any other updates at the time?  control-center? GConf2?

Comment 2 Charles R. Anderson 2007-02-05 16:55:54 EST
I cannot reproduce this.
Comment 3 Ray Strode [halfline] 2007-02-05 17:57:01 EST
great to hear. Thanks.

Note You need to log in before you can comment on or make changes to this bug.