Bug 222615 - Mouse moves to left side of screen and stays there
Mouse moves to left side of screen and stays there
Status: CLOSED DUPLICATE of bug 294011
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-mouse (Show other bugs)
6
All Linux
medium Severity high
: ---
: ---
Assigned To: Kristian Høgsberg
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-15 03:48 EST by Mykel Alvis
Modified: 2008-08-02 19:40 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-20 06:04:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Current xorg.conf file. modified to add mouse coverage back in (2.02 KB, text/plain)
2007-01-15 16:10 EST, Mykel Alvis
no flags Details
With conf file, driver is IMPS/2 (26.41 KB, application/octet-stream)
2007-01-19 00:10 EST, Mykel Alvis
no flags Details
With conf file, driver is PS/2 (26.42 KB, application/octet-stream)
2007-01-19 00:11 EST, Mykel Alvis
no flags Details
No conf file (56.79 KB, application/octet-stream)
2007-01-19 00:14 EST, Mykel Alvis
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 3113 None None None Never

  None (edit)
Description Mykel Alvis 2007-01-15 03:48:34 EST
Description of problem:

After a few minutes, sometimes only a few seconds, the mouse becomes attracted
to the left side of the screen and stays there.  If you move the mouse very
slowly, you can get it to move away from the left edge.  Vertical movement is
unimpaired.  Also, in KDE the Mouse Navigation with num pad is unaffected.

The mouse I'm using is a MS Wireless Intellimouse Explorer 2.0. 
My video card is a geforce 6600

Version-Release number of selected component (if applicable):

Out of the box FC6 install from a DVD onto a AMD dual core system.
I added the livna repository and the kmod-nvidia install from that repo because
the PCI express video drivers are not part of the basic install.  This
kmod-nvidia package forced a kernel update.

uname -a returns
Linux hodur 2.6.18-1.2869.fc6 #1 SMP Wed Dec 20 14:51:19 EST 2006 i686 athlon
i386 GNU/Linux

How reproducible:

Install FC6.  Wait 5 minutes.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Mykel Alvis 2007-01-15 12:56:37 EST
Added the USB-to-PS2Mouse adapter and plugged in the PS2 Mouse and Keyboard
connectors instead of just using the single USB connecter used previously.
No change was observed.  The mouse once again became attracted to the left side
of the screen within about 15 seconds of constant movement.
Comment 2 Mykel Alvis 2007-01-15 13:09:37 EST
I failed to attempt the xorg bugzilla list before posting here.
This appears to be reported to Xorg already, at least for BSD.

Comment 3 Mykel Alvis 2007-01-15 13:10:32 EST
https://bugs.freedesktop.org/show_bug.cgi?id=3113
Comment 4 Mykel Alvis 2007-01-15 16:01:39 EST
Managed to upgrade errorneous i586 kernel installed by 
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=211941 to i686 using
instructions at https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=211941#c24

Did this in hopes of helping possible FPU issues (just a guess).  No change.  
kmod-nvidia did some rather drastic changes to xorg.conf file, including
removing a backup.  Will attempt to restore some of those.
Comment 5 Mykel Alvis 2007-01-15 16:10:51 EST
Created attachment 145621 [details]
Current xorg.conf file. modified to add mouse coverage back in
Comment 6 Matěj Cepl 2007-01-16 09:33:41 EST
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server log file (/var/log/Xorg.*.log) to the bug report as
individual uncompressed file attachments using the bugzilla file attachment link
below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 7 James 2007-01-17 02:24:57 EST
I have noticed this same bug in the Fedora Core 6 LiveCD. It doesn't seem to
matter what I am doing, after a few seconds to several minutes, the mouse curser
will jump to the left side of the screen. I can slowly move it back towards the
center, but it always goes right back. Verticle movement is not affected.I am
unable (I assume) to save a log file on the LiveCD, but here are my specs.

AMD 3800+ x2
1GB RAM
ECS motherboard
Logitech scroll mouse
nVidia 6600 GT graphics card
Comment 8 Mykel Alvis 2007-01-19 00:10:31 EST
Created attachment 145963 [details]
With conf file, driver is IMPS/2
Comment 9 Mykel Alvis 2007-01-19 00:11:11 EST
Created attachment 145964 [details]
With conf file, driver is PS/2
Comment 10 Mykel Alvis 2007-01-19 00:14:58 EST
Created attachment 145965 [details]
No conf file

The desktop eventually came up (sort of) after being very messed up initially. 
This is a PCIExpress card (Nvidia GeForce 6600LE) and wouldn't detect at all
until installing the Nvidia update.

With no xorg.conf, the mouse was invisible, but didn't seem to do the left-side
thing.	However, the reported bug-effect does seem to happen most after some
significant amount of drawing on the screen(s) has occurred, like opening an
app window and moving it around a bit.	I didn't think to try that with this
no-conf  startup since it was impossible to tell where the pointer was so
grabbing the title bar was nearly as impossible.

Thanks for your help!
Comment 11 Mykel Alvis 2007-01-19 00:21:35 EST
As a little more information, I've tried a couple of things with my mouse
hardware.  I've switched from a USB-only mouse to using the little USB-to-PS/2
adapter that comes with MS Wireless keyboards.  I've also tried switching out
mice completely.  The two other PS/2 mice I've tried have precisely the same
behavior.
Comment 12 Mykel Alvis 2007-02-22 14:46:04 EST
Is there anything else I can do to help with this issue?  It's basically a
show-stopper for my primary desktop system.
Comment 13 bpaquier 2007-04-11 02:26:24 EDT
from the postings I could find in several forums, the issue seems to be due to
the  handling of the SMP.

Is there any resolution timeline for this bug? It prevents any owner of an AMD
dual core computer to do anything

Thx,
B.

H/w Config:
HP pavilion w/ ATI Express 200
AMD Dual Core 64 X2 2.13 GHz
Linux distro 2.6.18-1.2798.fc6


Comment 14 Ahmed Kamal 2007-04-21 10:08:17 EDT
Confirmed, I face this bug regularly after a lot of swapping usually after
waking up from hibernate. The mouse pointer is stuck at left-top corner, while
the actual mouse seems to be moving around the screen. So, if I keep
right-clicking while moving, it's easy to notice the mouse is actually moving,
it's just that the arrow is stuck up there!
This is very irritating, please fix it
Did we test the patch at https://bugs.freedesktop.org/show_bug.cgi?id=3113 ?
Comment 15 Ryan Hatfield 2007-06-03 09:55:25 EDT
I have exactly the same issue in Fedora 7.  I recently did a clean install of
Fedora 7 (i386) and am booting with the 2.6.20-2925.9.fc7xen kernel.

It appears to happen after an arbitrary amount of time once I start a virtual
machine (dom1) of Windows 2003 Server.  Every time this has happened the mouse
cursor was over one of the virt-manager windows though I'm not sure if that is
part of the cause.

Situation does not appear to occur when not running virt-manager.

The mouse is a generic USB wireless optical scroll mouse.

Problem goes away when ending the session via ctrl-alt-backspace.
Comment 16 Ryan Hatfield 2007-06-03 10:02:29 EDT
(In reply to comment #15)

Hardware:

Intel E6300 processor
Intel DG965WH motherboard
Nvidia 7600GS
1GB of RAM
Comment 17 Matěj Cepl 2007-09-20 06:04:09 EDT
This seems to be kernel-xen problem. Marking as duplicate.

*** This bug has been marked as a duplicate of 294011 ***

Note You need to log in before you can comment on or make changes to this bug.