Bug 222640 - Closing aterm with Control-d locks up my computer
Closing aterm with Control-d locks up my computer
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: aterm (Show other bugs)
6
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Andreas Bierfert
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-15 08:56 EST by Owen Platt
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-03 07:10:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Some basic system info from uname and lspci (8.92 KB, text/plain)
2007-01-19 09:02 EST, Owen Platt
no flags Details

  None (edit)
Description Owen Platt 2007-01-15 08:56:48 EST
Description of problem:
When I attempt to close an aterm window using Control-d, the system locks up and
I am unable to do anything except turn it off manually.

Version-Release number of selected component (if applicable):
1.0.0-6.fc6 (current version through yum)

How reproducible:
Easily reproduced, happens every time.

Steps to Reproduce:
1. Open an aterm
2. Press Control-d
  
Actual results:
System locks up.

Expected results:
Aterm window closes
Comment 1 Andreas Bierfert 2007-01-17 09:51:11 EST
I cannot reproduce this. What window manager do you use? Do you have selinux
enabled etc etc... and please give an strace of the crash if possible.
Comment 2 Owen Platt 2007-01-19 09:02:10 EST
Created attachment 145981 [details]
Some basic system info from uname and lspci
Comment 3 Owen Platt 2007-01-19 09:07:55 EST
I am unable to get an strace. Using the -o option doesn't write anything as it
never finished executing, and using "strace aterm > file" doesn't seem to work
either.

Selinux is enabled on my computer and I've had the problem under both Gnome and
FVWM so I don't think the window manager is the problem.

I've put up some system information in case that's any help.
Comment 4 Andreas Bierfert 2007-02-07 03:45:32 EST
I just pushed a new release with a fixed debuginfo package. If you find the time
please install the debuginfo package and maybe try something with gdb...
Comment 5 Andreas Bierfert 2007-06-03 07:10:28 EDT
Because of no response closing as CANTFIX. Fell free to reopen.

Note You need to log in before you can comment on or make changes to this bug.