Bug 222643 - GLblur demo make gnome desktop crash
GLblur demo make gnome desktop crash
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2007-01-15 09:26 EST by J.Jansen
Modified: 2008-05-07 04:59 EDT (History)
3 users (show)

See Also:
Fixed In Version: F7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-05-06 21:05:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
/etc/X11/xorg.conf (3.32 KB, text/plain)
2007-01-19 09:24 EST, J.Jansen
no flags Details
/var/log/Xorg.0.log (38.17 KB, text/plain)
2007-01-19 09:25 EST, J.Jansen
no flags Details
After the crash I logon in the Gnome-desk top and find this file in /var/log (33.27 KB, text/plain)
2007-04-10 04:00 EDT, J.Jansen
no flags Details
after crash and relogon in gnome-desktop (33.24 KB, application/octet-stream)
2007-04-10 04:01 EDT, J.Jansen
no flags Details

  None (edit)
Description J.Jansen 2007-01-15 09:26:40 EST
Description of problem:
When running the GLblur demo on my Acer Aspire 1700 in most cases the gnme
desktop (I did not test KDE) crashes and the login-screen reappears.

Version-Release number of selected component (if applicable):
all versions for FC6

How reproducible:
I only found it up to now on my laptop.

Steps to Reproduce:
1.upgrade to FC6 and xscreensaver fc6 version
Actual results:
when GLblur runs the gneme desktop may crash

Expected results:
a nice demo, which runs smoothly

Additional info:
Comment 1 Mamoru TASAKA 2007-01-15 10:48:11 EST
Well, these types of bug report (i.e. a hack broke my X server)
needs some more information, especially when you tried
GL hacks.
In most cases the cause is not xscreensaver hack but X server
or the tipset you are using if "X server crashed" as you
said. Please check:

If the cause is really /usr/libexec/xscreensaver/glblur, you
may gain some information using gdb after you install
xscreensaver debuginfo rpm. Would you try it?
Comment 2 Rex Dieter 2007-01-16 09:43:45 EST
Also, worth mentioning your video hardware, and which X driver you're using.
Comment 3 J.Jansen 2007-01-19 04:41:46 EST
The hard-ware : Acer 1700 laptop
                            grahics card: sis m650
I use the standard driver for this card which comes with FC6. I'm up to date
installing updates.

I;m pretty sure GLblur is the only problem, since :
           1) I saw it twice go when running this mode
           2) Even when I tried the small demo window in the "setup-window"
                it crashed the X-session
           3) disabling GLblur and leaving all the other modes in makes
                the crash disappear in several overnight tests.

I could do the gdb part ( how should I run this? any suggestion?)

If you are right and it is an X-bug, which only appears very rarely to whom
should we relay this bug?


Comment 4 Mamoru TASAKA 2007-01-19 06:59:49 EST
A. First try this. If this is due to glblur bug,
   some message should be gained.

A-1. # yum -y install xscreensaver-debuginfo mesa-debuginfo
       (note: Both packages are _very_ large!!
              xscreensaver-debuginfo: 12.8M
              mesa-debuginfo        : 72.1M for i386)
A-2  # yum -y install gdb
A-3  $ gdb /usr/libexec/xscreensaver/glblur
A-4  (gdb) run

.... If glblur crashes, then:
A-5  (gdb) bt

     And please attach (not copy/paste) the result.

.. When X crashes after this:
B-1 Please attach 
    * /etc/X11/xorg.conf
    * /var/log/Xorg.0.log
    ... and I will ask X maintainers for advice.
Comment 5 J.Jansen 2007-01-19 09:20:04 EST
Doing the above make the session crash within a minute. I attached the required
Comment 6 J.Jansen 2007-01-19 09:24:59 EST
Created attachment 145983 [details]
Comment 7 J.Jansen 2007-01-19 09:25:37 EST
Created attachment 145984 [details]
Comment 8 Mamoru TASAKA 2007-01-19 09:46:46 EST
Once switching to X server.

Dear X maintainers, any advice?
Comment 9 Adam Jackson 2007-04-05 16:27:02 EDT
I suspect this is another instance of the various renderbuffer bugs in Mesa atm.
 If you could attach the X log from the actual crash that would be helpful, as
it should contain a backtrace at the end.
Comment 10 J.Jansen 2007-04-10 04:00:36 EDT
Created attachment 152119 [details]
After the crash I logon in the Gnome-desk top and find this file in /var/log
Comment 11 J.Jansen 2007-04-10 04:01:31 EDT
Created attachment 152120 [details]
after crash and relogon in gnome-desktop
Comment 12 J.Jansen 2007-04-10 04:02:59 EDT
Hope these log files will lead you to the problem
Comment 13 J.Jansen 2007-05-07 10:26:26 EDT
After some updates, since about 2 weeks things became worse : All GL modes of
XscreenSaver started to "flicker" (even in the small "demo" window) and all have
the potential to crash the gnome session.

Comment 14 J.Jansen 2007-06-04 05:08:17 EDT
Last weekend I upgraded the machine to Fedora 7. Since then I could not
reproduce the crash and the GL-demos work fine again.

Comment 15 Bug Zapper 2008-04-03 14:54:05 EDT
Based on the date this bug was created, it appears to have been reported
against rawhide during the development of a Fedora release that is no
longer maintained. In order to refocus our efforts as a project we are
flagging all of the open bugs for releases which are no longer
maintained. If this bug remains in NEEDINFO thirty (30) days from now,
we will automatically close it.

If you can reproduce this bug in a maintained Fedora version (7, 8, or
rawhide), please change this bug to the respective version and change
the status to ASSIGNED. (If you're unable to change the bug's version
or status, add a comment to the bug and someone will change it for you.)

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we're following is outlined here:

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.
Comment 16 Bug Zapper 2008-05-06 21:05:26 EDT
This bug has been in NEEDINFO for more than 30 days since feedback was
first requested. As a result we are closing it.

If you can reproduce this bug in the future against a maintained Fedora
version please feel free to reopen it against that version.

The process we're following is outlined here:
Comment 17 J.Jansen 2008-05-07 04:59:07 EDT
According to comment #14 resolution should be "current release"

Note You need to log in before you can comment on or make changes to this bug.