Bug 222672 - IPW2200 Intel Wireless devices not configured or working properly under FC6
IPW2200 Intel Wireless devices not configured or working properly under FC6
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks: 427887
  Show dependency treegraph
 
Reported: 2007-01-15 12:00 EST by Greg Huber
Modified: 2008-01-08 10:43 EST (History)
2 users (show)

See Also:
Fixed In Version: F7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-08 10:43:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Greg Huber 2007-01-15 12:00:02 EST
Description of problem:
IPW2200 Intel wireless driver fails to configure devive as wireless
NetworkManager also fails to start and must be started manually.


Version-Release number of selected component (if applicable):
Fedora Core 6 (fully updated)
Kernel 2.6.18-1.2869.fc6


How reproducible:
On a system x86_64 based system with an Intel wireless card
installed, boot and attempt to configure interface


Steps to Reproduce:
1.boot
2.run NetworkManager
3.or run system-configure-network
  
Actual results:
Device appears as and ethernet (wired) device.


Expected results:
The device should be recgonized as a wireless device.
NetworkManager should popup and allow entries for the current network.

Additional info:
The device fails to work after attempting the following
1) forcing TYPE=Wireless in ifcfg-eth1 file.
2) replacing ipw2200 and ieee80211 drivers with current releases
3) updating firmware (/lib/firmware)
4) moving device from 'eth1' to 'wlan0' in ifcfg.wlan0 and modprobe.conf files

This laptop was recently upgraded (clean install) from FC5. Under FC5 wireless
networking was working prefectly.
Comment 1 Greg Huber 2007-01-15 13:02:28 EST
I should have mentioned that I an using an Intel 2915ABG based mini-PCI card.
Comment 2 Daniel Riek 2007-01-17 22:04:20 EST
What are the versions of the driver you updated to?
Comment 3 Greg Huber 2007-01-18 09:29:04 EST
The drivers I currently have loaded are;
  ieee80211-1.2.16
  ipw22000-1.2.1
Both were compilied from source.
I also have firmware
  ipw2200-firmware-3.0-3
installed. I have not upgraded wpa_supplicant.

Last night I tried installing the configuration files from
the previous FC5 installation, no luck.
Comment 4 Greg Huber 2007-01-19 11:25:49 EST
I just updated to the 2.6.19-1.2895.fc6 kernel with no change.
It still appears that I can see the networks but I can't connect to them.
Comment 5 Greg Huber 2007-01-30 10:24:06 EST
Over the weekend I loaded the kernel from the FC5 backups and tried running
it. Wireless still failed, but, when I went back to the 2.6.19-1.2895 kernel
wireless started to work. So at this point it think that wireless within the
kernel is working, but the initial detection of the wireless device still
fails to properly detect and catorgize the device.
Comment 6 Jon Stanley 2008-01-07 20:48:33 EST
(This is a mass-update to all current FC6 kernel bugs in NEW state)

Hello,

I'm reviewing this bug list as part of the kernel bug triage project, an attempt
to isolate current bugs in the Fedora kernel.

http://fedoraproject.org/wiki/KernelBugTriage

I am CC'ing myself to this bug, however this version of Fedora is no longer
maintained.

Please attempt to reproduce this bug with a current version of Fedora (presently
Fedora 8). If the bug no longer exists, please close the bug or I'll do so in a
few days if there is no further information lodged.

Thanks for using Fedora!
Comment 7 Greg Huber 2008-01-08 09:27:50 EST
I have since moved on to Fedora 7 where everything seems to be working.
Fedora 8 is not an option, yet...
I see no reason this bug cannot be closed.

Thank You.

Note You need to log in before you can comment on or make changes to this bug.