Bug 222676 - Just updated nmh to 1.2 here
Just updated nmh to 1.2 here
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: nmh (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Josh Bressers
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-15 12:19 EST by Horst H. von Brand
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-15 21:29:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
SRPM for nmh-1.2 (840.52 KB, application/x-rpm)
2007-01-15 12:19 EST, Horst H. von Brand
no flags Details
nmh SRPM for CVS as of today (587.24 KB, application/x-rpm)
2007-01-15 15:56 EST, Horst H. von Brand
no flags Details

  None (edit)
Description Horst H. von Brand 2007-01-15 12:19:58 EST
Description of problem:
No problem, really; just wanted to fix some other stuff (that turned out to be a
legacy (mis)configuration), and updated nmh as part of seaching for the problem.
Seems to work fine here...

It seems I'm the only remaining user of this one, perhaps I should take over
maintainership for Fedora? ;-)

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Horst H. von Brand 2007-01-15 12:19:59 EST
Created attachment 145589 [details]
SRPM for nmh-1.2
Comment 2 Josh Bressers 2007-01-15 12:43:58 EST
I've been meaning to do this for a while now.  Honestly there have been several
rather important bugs fixed in the nmh CVS since 1.2.  It would probably make
more sense to pull from CVS rather than let anyone suffer through 1.2.
Comment 3 Josh Bressers 2007-01-15 12:47:47 EST
Also, as a note to myself, the locking patch is no longer needed as the packages
are now built using fcntl locking rather than dot locking.
Comment 4 Horst H. von Brand 2007-01-15 14:24:57 EST
Re #2: Never got to wrap my mind around CVS... and that after working /very/
confortably with RCS for some time. Go figure.

I got the nmh repo into git here right now. There sure are a /lot/ of changes
since 1.2. What would you propose doing? Add a (mega)patch from 1.2 -- present?
Add each commit as a separate patch (easily doable, but I shudder)?

Take this discussion to email?

Buzz off??
Comment 5 Josh Bressers 2007-01-15 14:46:26 EST
I'll probably pull a new tarball from CVS.  I think using a megapatch would be
rather counterproductive.
Comment 6 Horst H. von Brand 2007-01-15 15:56:06 EST
Created attachment 145619 [details]
nmh SRPM for CVS as of today

Needed some tweaks, see the %changelog in the SRPM.
Comment 7 Josh Bressers 2007-01-15 21:29:33 EST
I've added nmh-1.2-20070115cvs.1.fc7 to CVS this evening.  It's building now. 
Thanks for the help.  I would suggest any effort you wish to invest in the
development of nmh be spent working with the upstream project (we need all the
help we can get):
http://savannah.nongnu.org/projects/nmh/

Note You need to log in before you can comment on or make changes to this bug.