Bug 222693 - extra "-" in device maps name if vg or lv contains a "-"
extra "-" in device maps name if vg or lv contains a "-"
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: lvm2 (Show other bugs)
4.4
All Linux
low Severity low
: ---
: ---
Assigned To: Dave Wysochanski
Corey Marthaler
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-15 14:15 EST by Dave Wysochanski
Modified: 2007-11-16 20:14 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-17 16:26:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Wysochanski 2007-01-15 14:15:08 EST
Looks odd (see iscsi--vg-iscsi--stripe--lv0) - not sure if this is lvm2 or
device-mapper.

# dmsetup table
mpath45: 0 204800 multipath 1 queue_if_no_path 0 1 1 round-robin 0 1 1 8:64 1000
mpath44: 0 204800 multipath 1 queue_if_no_path 0 1 1 round-robin 0 1 1 8:48 1000
VolGroup00-LogVol01: 0 4063232 linear 104:2 13369728
mpath43: 0 204800 multipath 1 queue_if_no_path 0 1 1 round-robin 0 1 1 8:32 1000
VolGroup00-LogVol00: 0 13369344 linear 104:2 384
iscsi--vg0-iscsi--stripe--lv0: 0 344064 striped 3 128 253:4 384 253:3 384 253:2 384
[root@gfs1 /]# uname -a
Linux gfs1.hpperf.rdu.redhat.com 2.6.9-43.ELsmp #1 SMP Wed Jan 10 20:03:33 EST
2007 i686 i686 i386 GNU/Linux
[root@gfs1 /]# lvm version
  LVM version:     2.02.18-RHEL4 (2007-01-12)
  Library version: 1.02.14-RHEL4 (2007-01-12)
  Driver version:  4.5.5
[root@gfs1 /]# pvs
  /dev/sdb: read failed after 0 of 2048 at 0: Input/output error
  PV                VG         Fmt  Attr PSize  PFree
  /dev/cciss/c0d0p2 VolGroup00 lvm2 a-    8.34G 32.00M
  /dev/dm-2         iscsi-vg0  lvm2 a-   96.00M 40.00M
  /dev/dm-3         iscsi-vg0  lvm2 a-   96.00M 40.00M
  /dev/dm-4         iscsi-vg0  lvm2 a-   96.00M 40.00M
[root@gfs1 /]# lvs
  /dev/sdb: read failed after 0 of 2048 at 0: Input/output error
  LV               VG         Attr   LSize   Origin Snap%  Move Log Copy%
  LogVol00         VolGroup00 -wi-ao   6.38G
  LogVol01         VolGroup00 -wi-ao   1.94G
  iscsi-stripe-lv0 iscsi-vg0  -wi-a- 168.00M
[root@gfs1 /]# vgs
  /dev/sdb: read failed after 0 of 2048 at 0: Input/output error
  VG         #PV #LV #SN Attr   VSize   VFree
  VolGroup00   1   2   0 wz--n-   8.34G  32.00M
  iscsi-vg0    3   1   0 wz--n- 288.00M 120.00M
Comment 1 Alasdair Kergon 2007-01-15 14:27:04 EST
those were meant to be internal names - people don't need to use them

dmsetup is not needed in normal operation

'mount' output is more problematic - could be fixed in mount, or one thing we've
considered is ditching the symlinks, but nothing's going to change in this area
until everything comes under udev control
Comment 2 Dave Wysochanski 2007-01-17 16:26:37 EST
Got a minute to look at this and found the code/explanation - clearly necessary
and not a bug.  

lib/misc/lvm_string.c:build_dm_name()

/*
 * Device layer names are all of the form <vg>-<lv>-<layer>, any
 * other hyphens that appear in these names are quoted with yet
 * another hyphen.  The top layer of any device has no layer
 * name.  eg, vg0-lvol0.
 */

Note You need to log in before you can comment on or make changes to this bug.