Bug 22273 - watch does not redirect program's input
Summary: watch does not redirect program's input
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: procps   
(Show other bugs)
Version: 6.2
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-12-14 00:14 UTC by Aleksey Nogin
Modified: 2007-04-18 16:30 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-11 12:31:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Aleksey Nogin 2000-12-14 00:14:42 UTC
When I run "watch program" and a program decides to talk to me and wait for
input, watch just hangs (without displaying any output at all). Watch
should probably redirect the stdin from /dev/null or do something similar
to prevent such situation.

I have procps-2.0.6-5, glibc-2.1.3-21, and kernel 2.2.16 installed of RH
6.2 system

Comment 1 Preston Brown 2001-02-01 20:34:47 UTC
watch isn't designed for use with that sort of program.  Don't do that.

Comment 2 Aleksey Nogin 2001-02-01 21:45:06 UTC
I was doing "watch make" and it turned out that while it normally works, in some
cases make would run latex and latex would ask for input when there is a bug. 

In any case, since watch can not do anything reasonable anyway when the watch'ed
program wants input, why not redirect the input? It definitely wouldn't make
things worse, but it can make things better.

Comment 3 Daniel Walsh 2004-02-11 12:31:42 UTC
Closed stdin and reassigned to /dev/null.

procps-3.1.15-4.i386.rpm



Note You need to log in before you can comment on or make changes to this bug.