Bug 222760 - Group View does not always work when one or more repos don't maintain comps.xml
Group View does not always work when one or more repos don't maintain comps.xml
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: yumex (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Lauridsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-15 19:02 EST by Stewart Adam
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-12 03:58:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stewart Adam 2007-01-15 19:02:56 EST
Description of problem:
I'm not sure, but I think this problem is more easily reproduced when one repo
or more doesn't maintain a comps.xml, the Group view shows little or no
packages. Sometimes, a group will contain packages but have an empty name.

Version-Release number of selected component (if applicable):
yumex-1.2.2-1.0.fc6

How reproducible:
Sometimes

Steps to Reproduce:
1. Use various mixes of repos
2. Look at the Group View
  
Actual results:
See Description

Expected results:
Groups with no name go under 'Unknown' or 'Other', and packages are correctly
populated into each group.
Comment 1 Tim Lauridsen 2007-03-21 09:23:37 EDT
This is caused by some repos (Like Livna) dont use name tags in comps xml,
because they want to use the same name an description as the comps.xml in core.
I have submit a fix to yum upstream cvs (3.1.x), it will be included in
yum-3.1.5 for FC7.

Note You need to log in before you can comment on or make changes to this bug.