Bug 222761 - Wine crashes with x11drv_main.c: X11DRV_CritSection error during loading.
Wine crashes with x11drv_main.c: X11DRV_CritSection error during loading.
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: wine (Show other bugs)
6
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Andreas Bierfert
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-15 19:25 EST by Mike Hunt
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-16 11:35:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mike Hunt 2007-01-15 19:25:40 EST
Description of problem:
Wine crashes with x11drv_main.c: X11DRV_CritSection error during loading.


Version-Release number of selected component (if applicable):
0.9.27-1 and 0.9.29


How reproducible:
Installing either version and trying to run.
http://forums.fedoraforum.org/showthread.php?p=722646#post722646
see above link for others with this issue.

Steps to Reproduce:
1.yum install wine
2.wine-config (creates .wine directory then gives error)
3.wine (gives error)
  
Actual results:
err:ntdll:RtlpWaitForCriticalSection section 0x6048f1a0 "x11drv_main.c:
X11DRV_CritSection" wait timed out in thread 000c, blocked by 000b, retrying (60
sec)
wine: Critical section 6048f1a0 wait failed at address 0x63d9f400 (thread 000c),
starting debugger...
Unhandled exception: wait failed on critical section 0x6048f1a0
thread_data_tls_index+0x44
err:seh:raise_exception Unhandled exception code c0000194 flags 0 addr 0x63d9f400
Process of pid=0x0000000a has terminated
No process loaded, cannot execute 'echo Modules:'
Cannot get info on module while no process is loaded
No process loaded, cannot execute 'echo Threads:'
process tid prio (all id:s are in hex)
00000008
0000000d 15
00000009 0


Expected results:
A running program :)


Additional info:
Pentium 4 1.8GHz on Asus P4B533, 1024MB PC-2100RAM@133MHzDDR, Nvidia GeForce4
4200Ti AGP4x.
Clean Fedora Core 6 install updated Kernel 2.6.18-1.2869.fc6 i686 with Livna
repo installed 'nvidia' module and driver.
Same error with FC6 installed 'nv' module.
Same error with SELinux enabled/disabled.
http://sourceforge.net/project/downloading.php?group_id=6241&use_mirror=umn&filename=wine-0.9.2-1fc4winehq.i686.rpm&84346251
Above link is for wine 0.9.2-1fc4 which installs and runs stable on this system
with Kernel 2.6.18-1.2869.fc6 i686 and nvidia module.
Comment 1 Andreas Bierfert 2007-01-17 09:54:27 EST
strange thing... I just checked with 0.9.29 and it works here without a problem.
Did you try to move your wine directory out of the way and start from scratch?
Comment 2 Andreas Bierfert 2007-04-16 11:35:37 EDT
It has been three month and no reply. I will close this bug. Feel free to reopen
if this issue is still occuring.

Note You need to log in before you can comment on or make changes to this bug.