Bug 222766 - DevIL needs link with allegro
DevIL needs link with allegro
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: DevIL (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ian Chapman
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-15 21:45 EST by Juan Manuel Borges Caño
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-17 14:35:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Juan Manuel Borges Caño 2007-01-15 21:45:46 EST
Description of problem:

the bug:
gcc  -g -O2   -o nehe-6 `sdl-config --libs` -lGL -lGLU  -lalleg_unsharable
image.o nehe.o nehe-6.o -lIL -lILUT
/usr/lib/liballeg.so.4.2: undefined reference to `_poly_zbuf_atex_mask_trans15'
...

anyway i don't use allegro, i only wan't to use DevIL, and the need to link with
a library that i don't use is not good for me. Maybe if DevIL uses pkg-config,
should resolve this bug?

Version-Release number of selected component (if applicable):
latest

How reproducible:
trying to program with DevIL, trying to link with DevIL

Steps to Reproduce:
1.
2.
3.
  
Actual results:
linkage failure

Expected results:
to work fine

Additional info: maybe the command from gcc is incomple, pkg-config would do it well
Comment 1 Ian Chapman 2007-01-17 09:52:41 EST
DevIL is intentionally not linked with liballeg_unsharable because the resultant
library is not PIC compliant. This causes problems for SELinux. This means when
linking you'll need to add  `allegro-config --libs`  to the linking line, or
similar. If this is not appropriate for you, you'll have to explain in more
detail why.  

Comment 2 Juan Manuel Borges Caño 2007-01-17 14:18:43 EST
No, that's all. Thank you.
Maybe DevIL should include a pkg-config file for this issues.
Comment 3 Ian Chapman 2007-01-17 14:35:42 EST
Thanks for the suggestion, I'll consider using pkg-config but I'll need to look
in more detail before making a decision :). For the moment, I'll close this bug.
Thanks.

Note You need to log in before you can comment on or make changes to this bug.