Bug 222808 - (CVE-2007-0002) CVE-2007-0002 buffer overflows
CVE-2007-0002 buffer overflows
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: libwpd (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
impact=important,source=vendorsec,rep...
: Security
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-16 04:56 EST by Mark J. Cox (Product Security)
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version: RHSA-2007-0055
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-16 10:18:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
EMBARGOED proposed patch against 0.8.8 (14.71 KB, patch)
2007-01-16 04:56 EST, Mark J. Cox (Product Security)
no flags Details | Diff
updated patch against the wpd we're shipping in RHEL-5 (18.01 KB, patch)
2007-01-16 06:54 EST, Caolan McNamara
no flags Details | Diff

  None (edit)
Description Mark J. Cox (Product Security) 2007-01-16 04:56:04 EST
iDefense discovered a TablesGroup Heap Overflow Vulnerability in libwpd.  We're
waiting on the full details but it's likely that an attacker could create a
malicious WordPerfect file that could execute arbitrary code if opened by a
victim in an application using libwpd such as OpenOffice.

No date on embargo; not sure if this will make it before GA or need a 0day.
Comment 1 Mark J. Cox (Product Security) 2007-01-16 04:56:04 EST
Created attachment 145665 [details]
EMBARGOED proposed patch against 0.8.8
Comment 2 Caolan McNamara 2007-01-16 06:54:25 EST
Created attachment 145676 [details]
updated patch against the wpd we're shipping in RHEL-5
Comment 3 Mark J. Cox (Product Security) 2007-01-18 04:40:59 EST
This will need a 0day, won't make GA
Comment 4 Paul Gampe 2007-02-01 14:00:28 EST
Approving for CVS commit.
Comment 5 Caolan McNamara 2007-02-01 15:44:36 EST
RHEL-5:libwpd-0.8.7-2.el5
Comment 11 Mark J. Cox (Product Security) 2007-03-16 10:13:32 EDT
removing embargo, now public http://libwpd.sourceforge.net/news.html
Comment 12 Red Hat Bugzilla 2007-03-16 10:18:26 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHSA-2007-0055.html

Note You need to log in before you can comment on or make changes to this bug.