Bug 222816 - RFE: Update gfs2's ordered write mode to not use buffer heads
Summary: RFE: Update gfs2's ordered write mode to not use buffer heads
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: GFS-kernel (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: Steve Whitehouse
QA Contact:
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks: 329321
TreeView+ depends on / blocked
 
Reported: 2007-01-16 12:05 UTC by Steve Whitehouse
Modified: 2013-02-25 11:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-25 11:38:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Steve Whitehouse 2007-01-16 12:05:56 UTC
It should be possible to avoid the user of buffer heads in the ordered write
mode by tagging each transaction and/or inode to indicate which page range(s)
need writing back at journal flush time. It might also be ok to just writeback
all dirty data for the inode in question without too much of a performance hit
since we'll only be doing it on a journal flush.

Either way it has two desirable properties: (1) we'd be able to move
gfs2_writepages() for ordered write files to use mpage_writepages() as per the
data=writeback mode and (2) we'd be able to get rid of all the ordered write
special casing in the databuf_ functions in lops.c which would considerably
simplify that code.


Note You need to log in before you can comment on or make changes to this bug.