Bug 222818 - Error in I830WaitLpRing()
Error in I830WaitLpRing()
Status: CLOSED DUPLICATE of bug 431340
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
6
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-16 07:22 EST by Ilya Ryabinkin
Modified: 2008-08-02 19:40 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-13 05:56:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.log with errors. (67.30 KB, text/plain)
2007-01-16 07:22 EST, Ilya Ryabinkin
no flags Details
xorg.conf (3.30 KB, text/plain)
2007-01-23 14:36 EST, Ilya Ryabinkin
no flags Details
Xorg.0.log when no xorg.conf has been supplied (64.83 KB, text/plain)
2007-01-31 07:50 EST, Ilya Ryabinkin
no flags Details
xorg log file showing I830WaitLpRing error (66.11 KB, text/plain)
2007-02-02 10:49 EST, James
no flags Details
xorg config file (2.98 KB, text/plain)
2007-02-02 10:51 EST, James
no flags Details

  None (edit)
Description Ilya Ryabinkin 2007-01-16 07:22:33 EST
Description of problem:

Xorg lock up my laptop (Dell Latitude D610, i915GM chipset), restart is
requred.Usually it happens, when multimedia player is used. Bug seems to be
related with XV extension. Upgrade on the version 1.5 from updates-testing does
not help: no dri (glxinfo reported no dri) and garbaged colors in mplayer.

Version-Release number of selected component (if applicable):
xorg-drv-i810-1.4.1


How reproducible:
Usually after several days of uptime, especially after coming out of suspend.


Steps to Reproduce:
1. Suspend computer
2. Resume
3. Use xine or mplayer with vo=xv
  
Actual results:
Black screen with mouse cursor in appearing periodically

Expected results:
Seamless work

Additional info:
Comment 1 Ilya Ryabinkin 2007-01-16 07:22:33 EST
Created attachment 145683 [details]
Xorg.log with errors.
Comment 2 Ilya Ryabinkin 2007-01-21 16:18:01 EST
Could anybody solve this problem? It's really annoying.
Comment 3 Matěj Cepl 2007-01-22 10:29:23 EST
Is it fresh install on clean disk or upgrade? Could you also attach your
/etc/X11/xorg.conf file to this bug as well, please?

Also, could you try to restart X without any /etc/X11/xorg.conf whatsoever? What
happens? 
Comment 4 Ilya Ryabinkin 2007-01-23 14:36:06 EST
Created attachment 146341 [details]
xorg.conf
Comment 5 Ilya Ryabinkin 2007-01-23 14:41:23 EST
> Is it fresh install on clean disk or upgrade

It is clean install. Two non-defalt options are presented in my xorg:
Option      "VBERestore" "true"
Option      "DisplayInfo" "false"

overwise, the laptop does not come out of suspend correctly: no video (black
screen) and Xorg eats 100% cpu (it can be seen through ssh). 
Comment 6 Ilya Ryabinkin 2007-01-23 15:01:06 EST
> Also, could you try to restart X without any /etc/X11/xorg.conf whatsoever?

I've this test just now. X server did not start due to lack of core pointer
devices: "failed to initialize core devices". If you'd like, I can supply
Xorg.0.log 
Comment 7 Matěj Cepl 2007-01-29 20:49:31 EST
(In reply to comment #6)
> If you'd like, I can supply Xorg.0.log

Yes, please

Comment 8 Ilya Ryabinkin 2007-01-31 07:50:56 EST
Created attachment 147013 [details]
Xorg.0.log when no xorg.conf has been supplied
Comment 9 James 2007-02-02 10:49:41 EST
Created attachment 147232 [details]
xorg log file showing I830WaitLpRing error
Comment 10 James 2007-02-02 10:51:18 EST
Created attachment 147233 [details]
xorg config file

Caught a couple of my own just today. This thing's been going on for ages now.
Happened to me when starting Xine. Had been playing around with Compiz
previously. The machine had been up for about 4.5 days between suspends and
hibernations.

Error in I830WaitLpRing(), now is -2095434026, start is -2095436027
pgetbl_ctl: 0x1ffe0001 pgetbl_err: 0x0
ipeir: 0 iphdr: 1810000
LP ring tail: 188 head: 0 len: 1f001 start 0
eir: 0 esr: 0 emr: ffff
instdone: ffc0 instpm: 0
memmode: 108 instps: 0
hwstam: ffff ier: 22 imr: 9 iir: 200
space: 130672 wanted 131064
(II) I810(0): [drm] removed 1 reserved context for kernel
(II) I810(0): [drm] unmapping 8192 bytes of SAREA 0xded67000 at 0xb7ee6000

Fatal server error:
lockup

(II) AIGLX: Suspending AIGLX clients for VT switch
Error in I830WaitLpRing(), now is -2095432018, start is -2095434019
pgetbl_ctl: 0x1ffe0001 pgetbl_err: 0x0
ipeir: 0 iphdr: 1810000
LP ring tail: 190 head: 0 len: 1f001 start 0
eir: 0 esr: 0 emr: ffff
instdone: ffc0 instpm: 0
memmode: 108 instps: 0
hwstam: ffff ier: 22 imr: 9 iir: 280
space: 130664 wanted 131064

FatalError re-entered, aborting
lockup

Logs and config attached above.
Comment 11 Ilya Ryabinkin 2007-02-05 02:43:23 EST
A lot of changes is in a new kernel 2.6.20 concerning drm and i915. Does it
mean, that the problem is in kernel too? Could we expect improvements upon
migration to a new kernel?
Comment 12 James 2007-03-17 17:59:44 EDT
Another one hit the windshield tonight. Happened when I started to watch a video
with RealPlayer.


(II) I810(0): [drm] removed 1 reserved context for kernel
(II) I810(0): [drm] unmapping 8192 bytes of SAREA 0xded7d000 at 0xb7eff000
Error in I830WaitLpRing(), now is 1641161875, start is 1641159874
pgetbl_ctl: 0x1ffe0001 pgetbl_err: 0x0
ipeir: 0 iphdr: 1810000
LP ring tail: 188 head: 0 len: 1f001 start 0
eir: 0 esr: 0 emr: ffff
instdone: ffc0 instpm: 0
memmode: 108 instps: 0
hwstam: ffff ier: 0 imr: ffff iir: 0
space: 130672 wanted 131064

Fatal server error:
lockup

(II) AIGLX: Suspending AIGLX clients for VT switch

Backtrace:
0: /usr/bin/Xorg(xf86SigHandler+0x81) [0x80e4ea1]
1: [0x206420]
2: /usr/lib/xorg/modules/extensions/libglx.so [0x177d9c]
3: /usr/bin/Xorg(AbortDDX+0xad) [0x80a0d3d]
4: /usr/bin/Xorg(AbortServer+0x23) [0x81addf3]
5: /usr/bin/Xorg(FatalError+0x66) [0x81ae386]
6: /usr/lib/xorg/modules/drivers/i810_drv.so(I830WaitLpRing+0x11b) [0x5c30cb]
7: /usr/lib/xorg/modules/drivers/i810_drv.so(I830Sync+0x104) [0x5c3894]
8: /usr/lib/xorg/modules/drivers/i810_drv.so [0x5c99d4]
9: /usr/lib/xorg/modules/drivers/i810_drv.so [0x5caa24]
10: /usr/lib/xorg/modules/drivers/i810_drv.so [0x5cf833]
11: /usr/lib/xorg/modules/libshadow.so [0x1c32be]
12: /usr/bin/Xorg [0x8154f67]
13: /usr/bin/Xorg [0x80c2f59]
14: /usr/bin/Xorg [0x812c178]
15: /usr/bin/Xorg [0x8151de5]
16: /usr/bin/Xorg [0x819daea]
17: /usr/bin/Xorg(main+0x4fc) [0x806fadc]
18: /lib/libc.so.6(__libc_start_main+0xdc) [0xb7ff2c]
19: /usr/bin/Xorg(FontFileCompleteXLFD+0x1e9) [0x806eda1]

FatalError re-entered, aborting
Caught signal 11.  Server aborting


xorg-x11-drv-i810-1.6.5-10.fc6
kernel-2.6.20-1.2925.fc6
Comment 13 James 2007-10-13 13:44:26 EDT
Again, with RealPlayer:

(II) AIGLX: Suspending AIGLX clients for VT switch
Error in I830WaitLpRing(), now is -1703994067, start is -1703996068
pgetbl_ctl: 0x1ffe0001 pgetbl_err: 0x0
ipeir: 0 iphdr: 1810000
LP ring tail: 178 head: 0 len: 1f001 start 0
eir: 0 esr: 0 emr: ffff
instdone: ffc0 instpm: 0
memmode: 108 instps: 0
hwstam: ffff ier: 22 imr: 9 iir: 280
space: 130688 wanted 131064
(II) I810(0): [drm] removed 1 reserved context for kernel
(II) I810(0): [drm] unmapping 8192 bytes of SAREA 0xdfbf5000 at 0xb7f8f000

Fatal server error:
lockup

(II) AIGLX: Suspending AIGLX clients for VT switch
Error in I830WaitLpRing(), now is -1703991066, start is -1703993067
pgetbl_ctl: 0x1ffe0001 pgetbl_err: 0x0
ipeir: 0 iphdr: 1810000
LP ring tail: 180 head: 0 len: 1f001 start 0
eir: 0 esr: 0 emr: ffff
instdone: ffc0 instpm: 0
memmode: 108 instps: 0
hwstam: ffff ier: 22 imr: 9 iir: 280
space: 130680 wanted 131064

FatalError re-entered, aborting
lockup

kernel-2.6.22.9-91.fc7
xorg-x11-drv-i810-2.0.0-4.fc7
Comment 14 Matěj Cepl 2007-12-10 04:22:08 EST
Fedora Core 6 is no longer supported, could you please reproduce this with the
updated version of the currently supported distribution (Fedora 7, 8, or
Rawhide)? If this issue turns out to still be reproducible, please let us know
in this bug report. If after a month's time we have not heard back from you, we
will have to close this bug as CANTFIX.

Setting status to NEEDINFO, and awaiting information from the reporter.

[This is mass-filed message to all open Fedora Core 6 bugs related to Xorg or
Gecko. If you see any other reason, why this bug shouldn't be closed, please,
comment on it here.]
Comment 15 Jesse Barnes 2008-01-10 17:07:41 EST
The latest intel driver has several Xv & VT switch related fixes, so hopefully 
it'll work for you.  Please re-test and confirm.
Comment 16 Pat Kane 2008-02-04 09:13:57 EST
See bug 431340 for a related problem
 https://bugzilla.redhat.com/show_bug.cgi?id=431340
Comment 17 Matěj Cepl 2008-02-13 05:56:26 EST

*** This bug has been marked as a duplicate of 431340 ***

Note You need to log in before you can comment on or make changes to this bug.