Bug 222825 - Prelink segfaults (again)
Prelink segfaults (again)
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: prelink (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
bzcl34nup
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-16 08:16 EST by david.hagood
Modified: 2008-05-05 19:02 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-05 19:02:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description david.hagood 2007-01-16 08:16:40 EST
Description of problem:
Prelink segfaults when run from cron daily

Version-Release number of selected component (if applicable):
prelink-0.3.10-1

How reproducible:
Every time

Steps to Reproduce:
1. /usr/sbin/prelink -av -mR -f
2.
3.
  
Actual results:
prelink segvs


Expected results:
prelink should run to completion

Additional info:
See bugs #200160, #147763, #196941, #198811 - this seems to be a reocurring problem.

running under gdb gives the following:
...
Prelinking /usr/lib/rpm/rpmdb_load
Prelinking /usr/lib/libgcj.so.7rh.0.0
/usr/sbin/prelink: /usr/lib/libgcj.so.7rh.0.0: Symbol section index outside of
section numbers

Program received signal SIGSEGV, Segmentation fault.
0x0808ce43 in elf_getdata ()
(gdb) bt
#0  0x0808ce43 in elf_getdata ()
#1  0x08069760 in close_dso_1 (dso=0x824f060) at dso.c:1623
#2  0x0806984f in close_dso (dso=0x824f060) at dso.c:1656
#3  0x0804d75d in prelink_ent (ent=0x815f4a0) at doit.c:250
#4  0x0804d579 in prelink_ent (ent=0x81de698) at doit.c:85
#5  0x0804dc45 in prelink_all () at doit.c:269
#6  0x080598a5 in main (argc=4, argv=0xbfb23564) at main.c:409
#7  0x080923b8 in __libc_start_main ()
#8  0x08048131 in _start ()
Comment 1 Bug Zapper 2008-04-03 14:54:31 EDT
Based on the date this bug was created, it appears to have been reported
against rawhide during the development of a Fedora release that is no
longer maintained. In order to refocus our efforts as a project we are
flagging all of the open bugs for releases which are no longer
maintained. If this bug remains in NEEDINFO thirty (30) days from now,
we will automatically close it.

If you can reproduce this bug in a maintained Fedora version (7, 8, or
rawhide), please change this bug to the respective version and change
the status to ASSIGNED. (If you're unable to change the bug's version
or status, add a comment to the bug and someone will change it for you.)

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.
Comment 2 david.hagood 2008-04-03 18:33:47 EDT
Go ahead and close this out - this seems to be one of those on again, off again
issues. If it resurfaces I'll reopen the bug.
Comment 3 John Poelstra 2008-05-05 19:02:13 EDT
Thank for your update.

Note You need to log in before you can comment on or make changes to this bug.