Bug 222835 - yum-updatesd does not log updates
yum-updatesd does not log updates
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
6
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-16 09:36 EST by Gerald Leung
Modified: 2014-01-21 17:56 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-06 02:13:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gerald Leung 2007-01-16 09:36:14 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.1) Gecko/20061222 Firefox/2.0.0.1

Description of problem:
When yum-updatesd updates packages, it does not log to /var/log/yum.log. If I were to update using Yum through command line, changes to system packages are logged to /var/log/yum.log. I can check that some packages were updated by running the command "rpm -qa -last | head -n 10" which shows packages were updated.

Contents of /etc/yum/yum-updatesd.conf:
[main]
# how often to check for new updates (in seconds)
run_interval = 3600
# how often to allow checking on request (in seconds)
updaterefresh = 600

# how to send notifications (valid: dbus, email, syslog)
emit_via = syslog
syslog_facility = DAEMON
syslog_level = NOTICE

# automatically install updates
do_update = yes
# automatically download updates
do_download = yes
# automatically download deps of updates
do_download_deps = yes

Contents of /etc/yum.conf:
[main]
cachedir=/var/cache/yum
keepcache=0
debuglevel=2
logfile=/var/log/yum.log
pkgpolicy=newest
distroverpkg=redhat-release
tolerant=1
exactarch=1
obsoletes=1
# We don't want to gpg-check local, unsigned packages
#gpgcheck=1
# Changed this because some mirrors go down and then
# re-trying takes forever.
retries=1
timeout=10


Version-Release number of selected component (if applicable):
yum-updatesd-3.0.1-2

How reproducible:
Always


Steps to Reproduce:
1. Make sure yum-updatesd is running.
2. Wait for yum-updatesd to respond to an update.

Actual Results:
yum-updatesd does not log updates to /var/log/yum.log.

Expected Results:
yum-updatesd logs updates to /var/log/yum.log.

Additional info:
yum-3.0.1-2
sysklogd-1.4.1-39.2
Comment 1 Orion Poplawski 2007-01-22 12:51:39 EST
This also happens when yum is run like the old yum cron:
        
/usr/bin/yum -R 120 -e 0 -d 1 -y shell /etc/yum/yum-daily.yum

# cat /etc/yum/yum-daily.yum
update
ts run
exit

No updates are logged to /var/log/yum.log.  

This is with 3.0.3-1.fc6 (upgraded before the general update).
Comment 2 Richard Hitt 2007-01-22 21:34:01 EST
My symptom is exactly like Orion's, with the same yum version.  Moreover, the
"Updated: " lines that as well appeared at /var/log/messages also stopped
appearing.  In both files /var/log/yum/log and /var/log/messages the very last
"Updated: " line reads as follows:
    Jan 16 04:31:49 Updated: yum.noarch 3.0.3-1.fc6
so it's apparent that the updating of this package caused further writes to
/var/log/yum.log and /var/log/messages to stop.
Comment 3 Akemi Yagi 2007-01-26 11:56:39 EST
I am having the same problem as Orion's.  yum stopped logging to
/var/log/yum.log after  yum.noarch 3.0.3-1.fc6 was installed. However, if I run
yum manually, it writes to the log file.
Comment 4 Gerald Leung 2007-01-27 10:35:53 EST
In my original comment, I said "If I were to update using Yum through command
line, changes to system packages are logged to /var/log/yum.log". By "command
line", I meant manually entering a command such as "yum update somepackage"
manually to install/update/delete a package. I currently have yum-3.0.3-1.fc6
installed.
Comment 5 Simon Andrews 2007-02-01 04:53:38 EST
Having had the same issue (nothing in yum.log after 3.0.3-1 was installed) I
played around with this.


It seems that you need at least -d2 for yum to write anything to yum.log. 
Unfortunately at this level it also spouts a load of other debugging information.


I too run yum from a cron job (with -e0 -d0 -y) and so don't want any debugging
output (unless it fails), but yum.log must be updated so I can track what's
actually gone on and so it can be picked up by logwatch.

Please can someone address this.  I'm only using a cron job because updatesd
stopeed logging anywhere, and now it seems that command line yum is now
similiarly broken.
Comment 6 Seth Vidal 2007-02-01 07:54:43 EST
it's being looked into, now. I'll update here when we have a fix.
Comment 7 Seth Vidal 2007-02-06 02:13:20 EST
This should be fixed in the next release of yum.

Note You need to log in before you can comment on or make changes to this bug.